Creare l'implementazione di riferimento di Primetime

Il riferimento TVSDK Primetime è un’applicazione Android basata sui framework TVSDK e AVE.

Per impostare e creare il progetto di riferimento Primetime in Eclipse:

  1. Scarica il file zip TVSDK Android e decomprimi in una directory in una posizione che ricorderai.

  2. Avvia Eclipse.

  3. Selezionare File > Import.

  4. Selezionare Android > Existing Android Code Into Workspace.

  5. Clic Next.

  6. Utilizza il pulsante Browse per compilare il campo Root Directory con la directory in samples/PrimetimeReference/src a cui hai decompresso il file zip TVSDK Android.

  7. Seleziona i seguenti progetti da importare: appcompat, PrimetimeReference.

  8. Clic Finish.

  9. Seleziona Project > Build Project per creare il progetto.

    Questo passaggio non è necessario se il progetto è configurato per la generazione automatica.

  10. Se desideri includere il progetto test nell’area di lavoro, associa il progetto test al progetto PrimetimeReference:

    1. Ripetere i passaggi 3. da 6 a 6.

    2. Seleziona il seguente progetto da importare: PrimetimeReference\tests.

    3. Clic Finish.

      Il progetto test ha una dipendenza dal progetto CatalogActivity ed è quindi necessario associare il progetto test al progetto CatalogActivity.

    4. Fai clic con il pulsante destro del mouse su tests e scegli Properties.

    5. Seleziona la scheda Projects in Percorso build Java.

    6. Clic Add…

    7. Seleziona Attività catalogo.

    8. Fai clic su OK per aggiungere il progetto.

    9. Fai clic su OK per uscire dalla pagina Proprietà .

    10. Seleziona Project > Build Project per creare il progetto.

      Questo passaggio non è necessario se il progetto è configurato per la generazione automatica.

In questa pagina