Notes de mise à jour du dernier pack de services Adobe Experience Manager 6.5

Dernière mise à jour : 2024-02-22

Informations sur la version

Produit Adobe Experience Manager 6.5
Version 6.5.20.0
Type Mise à jour du pack de services
Date Vendredi 22 février 2024
URL de téléchargement Distribution logicielle 

Éléments compris dans Experience Manager 6.5.20.0

Experience Manager 6.5.20.0 comprend de nouvelles fonctionnalités, des améliorations importantes demandées par les clientes et les clients, des correctifs de bugs ainsi que des améliorations en termes de performances, de stabilité et de sécurité, publiées depuis la version initiale 6.5 en avril 2019. Installez ce pack de services dans Experience Manager 6.5.

Principales fonctionnalités et améliorations

Voici quelques-unes des fonctionnalités et améliorations clés de cette version :

  • Dynamic Media prend désormais en charge le format d’image HEIC sans perte pour Apple iOS/iPadOS. Voir fmt dans l’API Dynamic Media Image Serving and Rendering.

  • Multisite Manager (MSM) prend désormais en charge les structures de fragments d’expérience, y compris les dossiers et les sous-dossiers, pour un déploiement en masse efficace des fragments d’expérience sur Live Copies.

Problèmes corrigés dans le Pack de services 20

Sites

Interface utilisateur d’administration

  • La variable Workflow Title est marqué par * selon les besoins, mais il n’y a aucune validation. (SITES-16491)

Content Fragments

  • Les dossiers de configuration imbriqués n’étaient plus pris en charge et les dossiers de modèles de fragments de contenu n’étaient plus visibles après la mise à niveau vers AEM 6.5.18 ou vers AEM 6.5.19. (SITES-18110) MAJEUR
  • Certains sous-dossiers ne peuvent pas effectuer de sélection à partir des modèles de fragment de contenu hérités. Il doit prendre en charge les dossiers sans avoir à jcr:content , même si les dossiers DAM créés par le biais de l’interface utilisateur en possèdent un. (SITES-17943)

Content Fragments - API GRAPHQL

  • Lors de l’exécution d’une requête GraphQL vers résultats de filtre utilisation de variables facultatives, si une valeur spécifique est not fourni pour la variable facultative, la variable est alors ignorée dans l’évaluation du filtre. (SITES-17051)

Content Fragments - API REST

  • Avec la mise à niveau de la org.json , il y a eu un changement dans la désérialisation des nombres décimaux. Avant d’être convertis "par défaut" en Doublons, puis en BigDecimals. Au lieu de cela, les valeurs de propriété de métadonnées, stockées par le biais de l’API REST, doivent être converties en Double à partir de BigDecimal. (SITES-16857)

Back-end principal

  • Lorsque la publication rapide d’un fragment de contenu est utilisée, le chargement se poursuit et n’est pas publié. En d’autres termes, la publication rapide ne fonctionne pas pour les fragments de contenu après une mise à niveau du Service Pack d’AEM 6.5.7 vers AEM 6.5.17. Lorsque l’utilisateur a essayé la publication gérée, cela a fonctionné. Cependant, lorsqu’ils tentaient la publication rapide, elle n’était pas publiée. Plus précisément : com.day.cq.wcm.core.impl.reference.ActivationReferenceSearchBuilder le système était à la corbeille. (SITES-17311)
  • Les fragments de contenu ne peuvent pas être sérialisés avec l’exportateur Jackson : le chargement de la page se déclenche lorsqu’un fragment de contenu est référencé dans une page (utilise le code de l’exportateur Jackson) et que toute balise est ajoutée à un fragment de contenu. (SITES-18096)

Composants principaux

  • Installation CIF package des composants principaux sur AEM causes :type valeur des composants existants à modifier. La modification signifie qu’ils ne sont plus rendus sur les pages auxquelles ils ont été ajoutés. (SITES-17601)

Intégration de campagne

  • AEM utilisait une liste autorisée également appelée whitelist-en raison d’un rapport de vulnérabilité. La liste autorisée empêchait les clients d’utiliser les fonctionnalités nécessaires. (SITES-16822)

Fragments d’expérience

  • MSM pour les fragments d’expérience prend désormais en charge le déploiement en masse vers les structures de contenu des fragments d’expérience, y compris les dossiers et les sous-dossiers. (SITES-16004)

MSM - Live Copies

  • Un "Is not modifiable" exception est générée lors du déploiement du composant. Plus précisément, un org.apache.sling.servlets.post.impl.operations.ModifyOperation exception survient lors du traitement de la réponse. (SITES-18809)
  • Impossible de déployer les modifications sur des Live Copies spécifiques des fragments d’expérience. (SITES-17930)
  • Lorsqu’un utilisateur ajoute une annotation à un composant sur une page de plan directeur, puis la déploie, le nombre d’annotations sur Live Copy s’affiche incorrectement. (SITES-17099)
  • Le bouton Déployer MSM d’une page parente à l’autre de la page enfant est rompu dans l’interface utilisateur graphique tactile. Lorsque cette option est sélectionnée, l’erreur suivante s’affiche : Uncaught TypeError: _g.shared is undefined. (SITES-16991)

Éditeur de page

  • L’aperçu de l’éditeur de thème Forms est interrompu. Lorsque l’option Aperçu est sélectionnée, seule une icône de chargement est visible. (SITES-17164)

Assets

  • Impossible de valider les champs basés sur des règles dans l’assistant de l’éditeur de métadonnées et affiche un message d’erreur "Champs obligatoires manquants". (ASSETS-31396)
  • Une fois qu’un PDF est déplacé vers un autre emplacement, la variable Afficher la page disparaît. (ASSETS-30538)
  • Impossible de sélectionner une image avec des autorisations de lecture. (ASSETS-32199)
  • Impossible de modifier la taille de la carte dans les paramètres d’affichage. (ASSETS-31667)
  • Le téléchargement échoue lors du téléchargement du type de fichier .oft. (ASSETS-30109)
  • Lorsque vous essayez d’ajouter un champ de métadonnées personnalisé en tant que colonne supplémentaire au rapport, les cases à cocher ne sont pas sélectionnées. (ASSETS-31671)
  • L’opération de déplacement de ressources ne fonctionne pas correctement dans le Service Pack 16 de Experience Manager. (ASSETS-30598)

Dynamic Media

  • Lorsqu’une ressource est chargée dans AEM, la variable Update_asset le workflow est déclenché. Cependant, le workflow ne se termine jamais. Le workflow se termine uniquement jusqu’à l’étape de chargement du produit. L’étape suivante est le chargement par lots Scene7, mais ce processus n’est pas extrait dans AEM. (ASSETS-30443)
  • Vous avez besoin d’un meilleur moyen de gérer les vidéos non-Dynamic Media avec élégance dans le composant Dynamic Media. Ce problème donnait une exception qui instanciait dynamicmedia_sly.js. (ASSETS-31301)
  • L’aperçu fonctionne pour toutes les ressources, les visionneuses de vidéos adaptatives et les vidéos. Cependant, il renvoie une erreur 403 pour .m3u8 les fichiers (qui, soit dit en passant, fonctionnent toujours par des liens publics). (ASSETS-31882)
  • La variable scene7SmartCropProcessingStatus correction de l’état. Recadrage intelligent des métadonnées vidéo utilisées pour afficher l’échec même en cas de réussite. (ASSETS-31255)

Forms

Les correctifs dans Experience Manager Forms sont fournis par le biais d’un package complémentaire distinct une semaine après la date de publication prévue du Pack de services Experience Manager. Dans ce cas, la publication du package complémentaire AEM 6.5.20.0 Forms est planifiée pour le vendredi 29 février 2024. Une liste des correctifs et améliorations de Forms est ajoutée à cette section après cette version.

Forms Designer

  • texte

Communities

  • Les diagnostics de synchronisation des utilisateurs échouent après la configuration de la synchronisation des utilisateurs. (NPR-41693)

Intégrations

  • Supprimez tout le code et les dépendances d’Adobe Search & Promote d’AEM 6.5. (NPR-40856)

Localisation

  • Le libellé Aria "close" n’est pas localisé dans Ressources > Fichiers, sélectionnez un dossier, puis, sur la barre d’outils, sélectionnez Propriétés > Autorisations onglet > nom du membre. (NPR-41705)
  • Il existe une info-bulle tronquée pour la variable Mot de passe du Key Store sur la page Configuration SSL pour les paramètres régionaux ENG, FRA, KOR, DEU et PTB. (NPR-41367)

Plateforme

  • Problème lors de l’intégration de Campaign avec AEM provoquée par le servlet /api ne renvoyant pas le schéma correct dans le href json. La raison en était que AEM ne recevait pas l’en-tête X-Forward-Proto, ce qui forçait la demande à répondre avec un modèle HTTP au lieu de HTTPS. Par conséquent, la possibilité d’activer/désactiver la sélection de schéma en fonction d’une configuration OSGI doit être ajoutée. (GRANITE-48454)

Sling

  • La variable org.apache.sling.resourceMerger Le lot 1.4.2 renvoie une exception à partir d’AEM 6.5, Service Pack 17 et versions ultérieures. La fusion des ressources Sling 1.4.4 doit être incluse dans le Service Pack 20. (NPR-41630)

Traduction

  • Suite au déploiement d’AEM 6.5 Service Pack 18, un problème s’est produit avec l’onglet Filtres de l’éditeur de règles de traduction. Lorsqu’un contexte est sélectionné, en cliquant sur Modifier > Enregistrer, un guillemet double apparaît comme caractère de HTML la prochaine fois que vous ouvrirez le même contexte. Essentiellement, les règles de traduction n’étaient pas correctement enregistrées. (NPR-41624)
  • Problèmes liés aux traductions de fragments de contenu, où les chaînes traduites sont renvoyées du fournisseur de traduction vers AEM, mais sont bloquées au niveau de la fonction /content/projects et ne pas mettre à jour les fragments de contenu. (NPR-41516)
  • Un message d’erreur s’affiche lors de la création d’une copie de langue. Elle se produit sur une page dont un fragment de contenu est référencé dans une propriété de page, à l’aide de modèles de fragment de contenu. (NPR-41441)
  • Les liens dans les fragments d’expérience ne sont pas ajustés à la langue correcte lors de la copie de la langue. Le fragment d’expérience pointe plutôt vers le paramètre régional principal. (NPR-41343)

Interface utilisateur

  • Une erreur de console se produit après une mise à niveau vers AEM 6.5, Service Pack 18. L’erreur se trouve dans la variable coralUI3.js et cela se produit lorsque vous sélectionnez une liste déroulante dans AEM. Plus précisément, cela se produit avec une onOverlayToggle . L’erreur Uncaught TypeError: Cannot read properties of null (reading 'innerText') s’affiche. (NPR-41467)
  • Dans AEM, Outils > Général > Balisage > Créer > Créer une balise, saisie de caractères non latins dans la variable Titre entraîne la création du champ Nom champ à remplir uniquement avec le trait d’union ( - ). (NPR-41623)
  • L’année du copyright est incorrecte dans la variable About Adobe Experience Manager de la boîte de dialogue (NPR-41526)
  • Il n’y a pas de traduction Propriétés du profil chaînes lors de la modification des paramètres utilisateur. Se produit dans tous les paramètres régionaux. (NPR-41365)

Installer Experience Manager 6.5.20.0

  • Experience Manager 6.5.20.0 nécessite Experience Manager 6.5. Consultez la documentation de mise à niveau pour des instructions détaillées.
  • Le téléchargement du Pack de services est disponible dans la Distribution logicielle d’Adobe.
  • Lors d’un déploiement avec MongoDB et plusieurs instances, installez Experience Manager 6.5.20.0 sur l’une des instances de création à l’aide du gestionnaire de modules.
IMPORTANT

Adobe ne recommande pas de supprimer ou de désinstaller le package Experience Manager 6.5.20.0. Par conséquent, avant d’installer le module, vous devez créer une sauvegarde du crx-repository au cas où vous auriez besoin de le restaurer.

Installation du pack de services sur Experience Manager 6.5

  1. Redémarrez l’instance avant l’installation si l’instance est en mode de mise à jour (lorsque l’instance a été mise à jour à partir d’une version antérieure). Adobe recommande un redémarrage si le temps de disponibilité actuel d’une instance est élevé.

  2. Avant l’installation, prenez un instantané ou exécutez une sauvegarde récente de votre instance Experience Manager.

  3. Téléchargez le pack de services à partir de la Distribution logicielle

  4. Ouvrez le gestionnaire de modules et cliquez sur Charger le module pour charger le module. Pour en savoir plus, consultez la section Gestionnaire de modules.

  5. Sélectionnez le module, puis sélectionnez Installer.

  6. Pour mettre à jour le connecteur S3, arrêtez l’instance après l’installation du pack de services, remplacez le connecteur existant par un nouveau fichier binaire fourni dans le dossier d’installation, puis redémarrez l’instance. Consultez la section Entrepôt de données S3 Amazon.

REMARQUE

La boîte de dialogue de l’interface utilisateur du gestionnaire de packages se ferme parfois pendant l’installation du pack de services. Adobe recommande d’attendre que les journaux d’erreurs se stabilisent avant d’accéder au déploiement. Attendez les journaux spécifiques liés à la désinstallation de la mise à jour complète pour vous assurer que l’installation est réussie. En règle générale, ce problème se produit dans Safari mais peut se produire par intermittence sur n’importe quel navigateur.

Installation automatique

Vous pouvez utiliser deux méthodes différentes pour installer automatiquement Experience Manager 6.5.20.0.

  • Placez le package dans le dossier ../crx-quickstart/install lorsque le serveur est disponible en ligne. Le package est automatiquement installé.
  • Utilisez l’API HTTP à partir du gestionnaire de packages. Utilisez cmd=install&recursive=true afin que les packages imbriqués soient installés.
REMARQUE

Experience Manager 6.5.20.0 ne prend pas en charge l’installation en Bootstrap.

Validation de l’installation

Pour connaître les plateformes certifiées pour travailler avec cette version, reportez-vous à la section des exigences techniques.

  1. La page d’informations sur les produits (/system/console/productinfo) affiche le numéro de version mis à jour Adobe Experience Manager (6.5.20.0) sous Produits installés. .

  2. Tous les bundles OSGi sont au statut ACTIF ou FRAGMENT dans la console OSGi (utilisez la console web : /system/console/bundles).

  3. Le lot OSGi org.apache.jackrabbit.oak-core est version 1.22.18 ou ultérieure (Utiliser la console web : /system/console/bundles).

Installer le Pack de services pour Experience Manager Forms

Pour obtenir des instructions sur l’installation du Pack de services sur Experience Manager Forms, voir les instructions d’installation du Pack de services Experience Manager Forms.

REMARQUE

La fonctionnalité de formulaires adaptatifs, disponible dans AEM 6.5 QuickStart, est conçue à des fins d’exploration et d’évaluation uniquement. Pour une utilisation à des fins de production, il est essentiel d’obtenir une licence valide pour AEM Forms, car la fonctionnalité de formulaires adaptatifs nécessite une licence appropriée.

Installer le package d’index GraphQL pour les fragments de contenu d’Experience Manager

La clientèle qui utilise GraphQL doit installer le fragment de contenu d’Experience Manager avec le package d’index GraphQL 1.1.1.

Vous pouvez ainsi ajouter la définition d’index requise selon les fonctionnalités que vous utilisez réellement.

L’échec de l’installation de ce package peut entraîner des requêtes GraphQL lentes ou en échec.

REMARQUE

N’installez ce package qu’une seule fois par instance ; il n’est pas nécessaire de le réinstaller avec chaque Pack de services.

UberJar

UberJar pour Experience Manager 6.5.20.0 est disponible dans le référentiel central Maven.

Pour utiliser UberJar dans un projet Maven, consultez la section Utilisation d’UberJar et incluez la dépendance suivante dans le POM de votre projet :

<dependency>
     <groupId>com.adobe.aem</groupId>
     <artifactId>uber-jar</artifactId>
     <version>6.5.20</version>
     <scope>provided</scope>
</dependency>
REMARQUE

UberJar et les autres artefacts associés sont disponibles sur le référentiel central Maven au lieu du référentiel Maven public Adobe (repo.adobe.com). Le fichier UberJar principal est renommé uber-jar-<version>.jar. Il n’existe donc pas de classifier avec apis comme valeur pour la balise dependency.

Fonctionnalités obsolètes et supprimées

Consultez les fonctionnalités obsolètes et supprimées.

Problèmes connus

  • Lié à Oak
    Depuis le pack de services 13 et les versions ultérieures, le journal d’erreur suivant a commencé à s’afficher, ce qui affecte le cache de persistance :

    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.0.202/5]
    at org.h2.mvstore.DataUtils.newMVStoreException(DataUtils.java:1004)
        at org.h2.mvstore.MVStore.getUnsupportedWriteFormatException(MVStore.java:1059)
        at org.h2.mvstore.MVStore.readStoreHeader(MVStore.java:878)
        at org.h2.mvstore.MVStore.<init>(MVStore.java:455)
        at org.h2.mvstore.MVStore$Builder.open(MVStore.java:4052)
        at org.h2.mvstore.db.Store.<init>(Store.java:129)
    

    Ou

    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.1.214/5].
    

    Pour résoudre cette exception, procédez comme suit :

    1. Supprimez les deux dossiers suivants de crx-quickstart/repository/

      • cache
      • diff-cache
    2. Installez le Pack de services ou redémarrez Experience Manager as a Cloud Service.
      Les nouveaux dossiers cache et diff-cache sont automatiquement créés et vous ne voyez plus d’exception liée à mvstore dans error.log.

  • Mettez à jour vos requêtes GraphQL qui peuvent avoir utilisé un nom d’API personnalisé pour votre modèle de contenu afin d’utiliser plutôt le nom par défaut du modèle de contenu.

  • Une requête GraphQL peut utiliser l’index damAssetLucene plutôt que l’index fragments. Il peut en résulter l’échec des requêtes GraphQL ou l’exécution de celles-ci peut prendre beaucoup de temps.

    Pour résoudre le problème, damAssetLucene doit être configuré pour inclure les deux propriétés suivantes sous /indexRules/dam:Asset/properties :

    • contentFragment
      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/contentFragment"
      • propertyIndex="{Boolean}true"
      • type="Boolean"
    • model
      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/data/cq:model"
      • ordered="{Boolean}true"
      • propertyIndex="{Boolean}true"
      • type="String"

    Une fois la définition d’index modifiée, une réindexation est nécessaire (reindex = true).

    Après ces étapes, les requêtes GraphQL doivent être plus rapides.

  • Lorsque vous tentez de déplacer, de supprimer ou de publier des fragments de contenu, des sites ou des pages, un problème se produit lorsque les références aux fragments de contenu sont récupérées, car la requête en arrière-plan échoue. En d’autres termes, la fonctionnalité ne fonctionne pas.
    Pour garantir le bon fonctionnement de cette opération, vous devez ajouter les propriétés suivantes au nœud de définition d’index /oak:index/damAssetLucene (aucune réindexation n’est requise) :

    "tags": [
        "visualSimilaritySearch"
      ]
    "refresh": true
    
  • Si vous mettez à niveau votre instance Experience Manager de 6.5.0 à 6.5.4, jusqu’au dernier Service Pack sur Java™ 11, les exceptions RRD4JReporter s’affichent dans le fichier error.log. Pour arrêter les exceptions, redémarrez votre instance d’Experience Manager.

  • Les utilisateurs peuvent renommer un dossier dans une hiérarchie dans Assets et publier un dossier imbriqué dans Brand Portal. Toutefois, le titre du dossier n’est pas mis à jour dans Brand Portal jusqu’à ce que le dossier racine soit republié.

  • Les erreurs et messages d’avertissement suivants peuvent s’afficher lors de l’installation d’Experience Manager 6.5.x.x :

    • « Lorsque l’intégration d’Adobe Target est configurée dans Experience Manager à l’aide de l’API Target Standard (authentification IMS), l’exportation de fragments d’expérience vers Target entraîne la création de types d’offres incorrects. » Au lieu du type « Fragment d’expérience » / source « Adobe Experience Manager », Target crée plusieurs offres avec le type « HTML » / source « Adobe Target Classic ».
    • com.adobe.granite.maintenance.impl.TaskScheduler : aucune fenêtre de maintenance n’a été trouvée sur granite/operations/maintenance.
    • La validation côté serveur du formulaire adaptatif échoue lorsque des fonctions d’agrégat telles que SUM, MAX et MIN sont utilisées (CQ-4274424).
    • com.adobe.granite.maintenance.impl.TaskScheduler - Aucune fenêtre de maintenance n’a été trouvée sur granite/operations/maintenance.
    • La zone réactive d’une image interactive de Dynamic Media n’est pas visible lors de la prévisualisation du fichier via la visionneuse de bannières avec achat.
    • com.adobe.cq.social.cq-social-jcr-provider bundle com.adobe.cq.social.cq-social-jcr-provider:1.3.5 (395)[com.adobe.cq.social.provider.jcr.impl.SpiSocialJcrResourceProviderImpl(2302)] : temporisation en attente de modification d’enregistrement pour terminer la désinscription.
  • À partir de la version 6.5.15 d’AEM, le moteur JavaScript Rhino fourni par le lot org.apache.servicemix.bundles.rhino a un nouveau comportement d’hébergement. Les scripts qui utilisent le mode strict (use strict;) doivent déclarer correctement leurs variables, sinon ils ne seront pas exécutés et génèreront une erreur d’exécution.

Problèmes connus d’AEM Forms

Plateformes prises en charge

  • JDK 11.0.20 n’est pas pris en charge pour installer le programme d’installation AEM Forms on JEE. Seules la version JDK 11.0.19 ou les versions antérieures sont prises en charge pour installer le programme d’installation AEM Forms on JEE. (FORMS-10659)

Installation

  • Sur la plateforme JBoss® 7.1.4, lorsque l’utilisateur ou l’utilisatrice installe le pack de services Experience Manager 6.5.16.0, le déploiement de adobe-livecycle-jboss.ear échoue. (CQ-4351522, CQDOC-20159)

  • Après l’installation du programme d’installation complet AEM Service Pack 6.5.20.0, le déploiement EAR échoue sur JEE à l’aide de JBoss® clé en main.

Pour résoudre le problème, recherchez le fichier <AEM_Forms_Installation_dir>\jboss\bin\standalone.bat et mettez à jour Adobe_Adobe_JAVA_HOME vers Adobe_JAVA_HOME pour toutes les occurrences avant d’exécuter Configuration Manager. (CQDOC-20803)

Installer le fragment de servlet (Pack de services AEM 6.5.14.0 ou version antérieure)

  • Si vous effectuez une mise à niveau vers AEM Service Pack 6.5.15.0 ou version ultérieure et que votre instance AEM fonctionne sur Tomcat 8.5.88, il est obligatoire d’installer le fragment de servlet. Procédez à cette installation before vous procédez à l'installation du Service Pack 6.5.15.0 ou supérieur.
  • Il est obligatoire d’installer le fragment de servlet pour tous les serveurs d’applications, à l’exception de ceux qui s’exécutent sur JBoss® EAP 7.4.0.

Pour installer le fragment de servlet :

  1. Téléchargez le fragment de servlet à partir de la Distribution logicielle.
  2. Démarrez le serveur d’applications.
  3. Attendez que les journaux se stabilisent et vérifiez l’état du bundle.
  4. Ouvrez les lots de la console web. L’URL par défaut est http://[Server]:[Port]/system/console/bundles.
  5. Cliquez sur Installer ou Mettre à jour.
  6. Sélectionner le fragment téléchargé
    org.apache.felix.http.servlet-api-1.2.0_fragment_full.jar
  7. Cliquez sur Installer ou Mettre à jour.
  8. Attendez que le serveur d’applications se stabilise.
  9. Arrêtez le serveur d’applications.

Formulaires adaptatifs

  • Lorsqu’un formulaire adaptatif est publié, toutes ses dépendances, y compris les stratégies, sont republiées, même si aucune modification ne leur a été apportée. (FORMS-10454)
  • Lorsqu’un utilisateur ou une utilisatrice choisit de configurer un champ pour la première fois dans un formulaire adaptatif, l’option permettant d’enregistrer une configuration ne s’affiche pas dans l’explorateur de propriétés. Sélectionner un autre champ du formulaire adaptatif à configurer dans le même éditeur pour résoudre le problème.
  • Lorsque des utilisateurs ou des utilisatrices exécutent l’action d’envoi, l’envoi échoue avec une erreur :
    javax.servlet.ServletException: java.lang.NoSuchMethodError
    Pour résoudre le problème, recompilez les scripts Sling tels que JSP, Java™ et Sightly. (FORMS-8542)
  • Après avoir installé le Pack de services AEM 6.5.14.0 et versions ultérieures, les utilisateurs et utilisatrices ne peuvent pas sélectionner de police dans l’interface utilisateur d’administration de JEE pour les documents PDF lorsqu’ils accèdent à Home > Services > PDF Generator > Adobe PDF Settings, car la liste des polices s’affiche vide. (FORMS-12095)
  • Dans AEM Forms on JEE, le rendu de HTML5 Forms qui utilise le chemin d’accès au contexte échoue. (FORMS-12485, FORMS-12691) Un correctif est disponible pour ce problème. Pour télécharger et installer le correctif, voir Correctifs Adobe Experience Manager Forms.
  • Le Forms adaptatif vous permet d’utiliser des fonctions personnalisées avec ECMAScript version 5 ou antérieure. Lorsqu’une fonction personnalisée utilise ECMAScript version 6 ou ultérieure, comme les fonctions "let", "const" ou flèches, l’éditeur de règles peut ne pas s’ouvrir correctement.

d’AEM Forms on JEE

  • Des vulnérabilités de sécurité critiques ont été signalées pour Struts 2 RCE, un framework d’applications web populaire et open source pour le développement d’applications web Java™ EE. Adobe a publié le pack de services 19.1 (6.5.19.1) pour AEM 6.5 afin de résoudre la vulnérabilité dans AEM Forms on JEE.

Bundles OSGi et packages de contenu inclus

Les documents texte suivants répertorient les lots OSGi et les packages de contenu inclus dans ce Experience Manager Version 6.5 du Service Pack :

Sites web à accès limité

Ces sites Web sont disponibles uniquement pour les clients. Si vous êtes client et avez besoin d’un accès, contactez votre responsable de compte Adobe.

Sur cette page