Paquete de compatibilidad

Última actualización: 2024-02-28
  • Creado para:
  • Admin

Información general

La comunicación interactiva es el método predeterminado y recomendado para crear comunicaciones con los clientes en AEM Forms 6.5. Para seguir utilizando cartas en AEM Forms 6.5, debe instalar el último Paquete de compatibilidad de AEMFD.

El Paquete de compatibilidad de AEMFD también le permite utilice los siguientes recursos de AEM Forms 6.4, 6.3 y 6.2 en AEM Forms 6.5:

  • Fragmentos de documento
  • Cartas
  • Diccionarios de datos
  • Plantillas y páginas obsoletas de formularios adaptables

Para obtener más información, consulte Recursos compatibles con AEM Forms 6.5 mediante la instalación del paquete Compatibilidad.

Agregue compatibilidad para los recursos de AEM Forms 6.4, 6.3 y 6.2 en AEM Forms 6.5

Después de realizar una actualización, haga lo siguiente para instalar el paquete de compatibilidad de AEMFD y hacer que sus recursos sean compatibles con la versión 6.5:

Asegúrese de que tiene preinstalado el paquete de compatibilidad de AEM.

  1. Instale la última versión 6.5 del paquete de compatibilidad.

    Para obtener más información sobre cómo cargar e instalar el paquete, consulte Cómo trabajar con paquetes.

  2. Una vez estabilizados los registros, reinicie el servidor.

  3. Utilice la utilidad de migración para hacer que los recursos sean compatibles con la versión 6.5.

    NOTA

    Se recomienda utilizar el comando "Ctrl + C" para reiniciar el SDK. AEM AEM El reinicio del SDK de la mediante métodos alternativos, como detener los procesos de Java, puede generar incoherencias en el entorno de desarrollo de la.

    Para obtener más información, consulte utilidad de migración.

Recursos compatibles con AEM Forms 6.5 mediante la instalación del paquete Compatibilidad

Al instalar el paquete Compatibilidad, puede hacer que los siguientes recursos y plantillas sean compatibles con AEM Forms 6.5:

  • Recursos de Administración de correspondencia de AEM 6.4 y anteriores:

  • Plantillas de formularios adaptables obsoletas:

    • /libs/fd/af/templates/blankTemplate2
    • /libs/fd/af/templates/simpleEnrollmentTemplate
    • /libs/fd/af/templates/simpleEnrollmentTemplate2
    • /libs/fd/af/templates/surveyTemplate
    • /libs/fd/af/templates/surveyTemplate2
    • /libs/fd/af/templates/tabbedEnrollmentTemplate
    • /libs/fd/af/templates/tabbedEnrollmentTemplate2
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate2
  • Páginas obsoletas de formularios adaptables:

    • /libs/fd/af/components/page/survey
    • /libs/fd/af/components/page/tabbedenrollment
    • /libs/fd/afaddon/components/page/advancedenrollment

En esta página