Instalar pacote de compatibilidade

A instalação do pacote Compatibilidade no AEM Forms 6.4 permite usar os ativos de Gerenciamento de correspondência do AEM Forms 6.3 e modelos e páginas de formulários adaptáveis obsoletos

Visão geral

A comunicação interativa é a abordagem padrão e recomendada para criar comunicações com clientes no AEM Forms 6.4. Para continuar usando as cartas do AEM 6.3 Forms e do AEM 6.2 Forms, é necessário instalar o Pacote de compatibilidade do AEMFD.

O pacote de compatibilidade do AEMFD permite usar os seguintes ativos do AEM Forms 6.3 e 6.2 no AEM Forms 6.4:

  • Fragmentos de documento criados no AEM Forms 6.3 e 6.2
  • Cartas
  • Dicionários de dados
  • Modelos e páginas obsoletas de formulários adaptáveis

Para obter mais informações, consulte Ativos compatíveis com o AEM Forms 6.4 instalando o pacote Compatibilidade.

Adicionar suporte para os ativos AEM Forms 6.3 e 6.2 no AEM Forms 6.4

Depois de executar uma atualização, faça o seguinte para instalar o pacote de compatibilidade do AEMFD e tornar seus ativos compatíveis com o 6.4:

Certifique-se de ter AEM pacote de compatibilidade pré-instalado.

  1. Instale o Pacote de Compatibilidade.

    Para obter mais informações sobre como fazer upload e instalar o pacote, consulte Como trabalhar com pacotes.

  2. Depois que os logs forem estabilizados, reinicie o servidor.

  3. Use o utilitário de migração para tornar seus ativos compatíveis com a 6.4.

    Para obter mais informações, consulte utilitário de migração.

Ativos compatíveis com o AEM Forms 6.4 ao instalar o pacote Compatibilidade

Ao instalar o pacote de Compatibilidade, você pode tornar os seguintes ativos e modelos compatíveis com o AEM Forms 6.4:

  • Ativos de gerenciamento de correspondência da AEM 6.3 e anteriores

  • Modelos adaptáveis obsoletos de formulário

    • /libs/fd/af/templates/blankTemplate2
    • /libs/fd/af/templates/simpleEnrollmentTemplate
    • /libs/fd/af/templates/simpleEnrollmentTemplate2
    • /libs/fd/af/templates/surveyTemplate
    • /libs/fd/af/templates/surveyTemplate2
    • /libs/fd/af/templates/tabbedEnrollmentTemplate
    • /libs/fd/af/templates/tabbedEnrollmentTemplate2
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate2
  • Páginas obsoletas para formulários adaptáveis:

    • /libs/fd/af/components/page/survey
    • /libs/fd/af/components/page/tabbedenrollment
    • /libs/fd/afaddon/components/page/advancedenrollment

Nesta página