Erstellen von Clustern

Wählen Sie Eingabevariablen, die Anzahl der Cluster und eine Zielpopulation (falls gewünscht) aus, um Cluster in Ihrem Datensatz zu definieren.

Erstellen von Clustern

  1. Öffnen Sie den Cluster Builder.

    Klicken Sie auf Visualisierung > Prädiktive Analyse > Clustering > Cluster-Builder.

  2. Wählen Sie Eingabevariablen aus.

    • Fügen Sie der Liste Input Variables Metriken hinzu, indem Sie aus dem Menü Metric in der Symbolleiste eine Auswahl treffen.

    • Fügen Sie Dimensionselemente zur Liste Input Variables hinzu, indem Sie sie aus der Tabelle einer Dimension ziehen.

      Drücken Sie die Taste Ctrl + Alt und ziehen Sie die ausgewählten Dimensionselemente in die Liste Input Variables oder in das Feld Element in der Symbolleiste.


      Standardmäßig wird das Clustering für den gesamten Datensatz durchgeführt. Sie können alle Eingabevariablen im linken Bereich Preprocessing sehen.

  3. Wählen Sie im Menü Options die gewünschte Anzahl von Clustern aus.

  4. Wenn Sie eine Untergruppe der Besucher in Ihrem Datensatz gruppieren möchten, können Sie einen Populationsfilter definieren.

    Definieren Sie zunächst die gewünschte Teilmenge mithilfe von Auswahlen in Workspace oder mithilfe von Filter Editor. Nachdem Sie die gewünschte Teilmenge ausgewählt haben, legen Sie die Zielpopulation im Menü Options fest. Es wird empfohlen, der Zielgruppe einen Identifizierungsnamen zu geben.

    Das Menü Options verfügt auch über Einstellungen, mit denen die maximale Anzahl von Durchgängen und der akzeptable Schwellenwert für mittlere Konvergenz gesteuert werden.

  5. Nachdem die Eingaben und Optionen konfiguriert wurden, klicken Sie auf die Schaltfläche Go , um das Clustering lokal auszuführen, oder drücken Sie Submit, um die Aufgabe an den Predictive Analytics-Server zu senden. Durch Übermittlungen an den Server wird die resultierende Dimension im Datensatz gespeichert, wenn die Konvergenz abgeschlossen ist.

    Wenn Sie lokal ausführen, sehen Sie, wie sich der Cluster Builder durch vier Baumkronen-Clustering-Phasen bewegt, da er intelligente Zentren basierend auf den Eingaben definiert.

    Sobald die Cluster-Zentren aufhören, mehr als den angegebenen Konvergenzschwellenwert zu ändern, wird die Cluster-Dimension konvertiert und der Cluster-Builder zeigt zusätzliche Informationen darüber an, wie relevant ein Input für jeden Cluster war.

  6. Passen Sie die Cluster an.

    Wenn Sie mit der rechten Maustaste auf die Farbleiste der Statistiken klicken, wird ein Kontextmenü geöffnet, in dem Sie die Relevanzschwellen anpassen können. Im Fall der Verteilung der Dimensionselemente können Sie festlegen, welcher Test angezeigt wird.

    Metrikeingaben bieten einen t-Test für jeden Cluster, während die Eingaben von Dimensionselementen drei Verteilungstests (Chi squared, eine entropy U-Statistik und Cramers V-Statistik) für jeden Cluster bereitstellen.

    HINWEIS

    Wenn Sie Eingaben während der Konvergenz hinzufügen oder entfernen, wird der Prozess angehalten, bis Sie die Taste Go erneut drücken.

    Nach dem Erstellen von Clustern können Sie die Farbauswahl öffnen, um Farben für unterschiedliche Verteilungsergebnisse zuzuweisen.

  7. Wenn die Cluster-Dimension konvertiert ist, können Sie der Tabelle Metriken hinzufügen und Auswahlen wie gewohnt vornehmen. Sie können auch mit der rechten Maustaste auf die Elementnamen (Cluster 1, Cluster 2 usw.) klicken, um das Kontextmenü zu öffnen und sie in eine aussagekräftigere Bezeichnung umzubenennen.

  8. Wenn Sie diese Cluster-Dimension in anderen Visualisierungen verwenden möchten, können Sie sie lokal oder Submit lokal für den Server verwenden.Save

Wenn Sie die Konvergenz erneut ausführen oder die Relevanz der Eingaben sehen möchten, kann Cluster Builder auch vorhandene Cluster-Dimensionen laden.

TIPP

Wenn diese Option aktiviert ist, werden alle Eingabevariablen vollständig freigegeben und Sie erhalten eine leere Cluster-Builder-Visualisierung, um neue Cluster zu definieren.Reset

Auf dieser Seite