Aggiornare Data Migration Tool

Per verificare che le versioni dell'installazione corrente del Magento 2 e Data Migration Tool corrispondono esattamente, potrebbe essere necessario aggiornare lo strumento.

Prerequisiti

Prima di aggiornare Data Migration Tool, devi:

  • Aggiornare il software di Magento per ottenere la versione più recente

  • Eseguire il backup vendor/magento/data-migration-tool directory

  • Assicurati che il Data Migration Tool La versione corrisponde alla versione dell'applicazione Magento

Aggiornare il software di Magento

Se non l'hai già fatto, aggiornare il software di Magento.

Eseguire il backup vendor/magento/data-migration-tool directory

Prima di aggiornare Data Migration Tool, effettua almeno il backup vendor/magento/data-migration-tool directory. Durante l’aggiornamento, potrebbe essere eliminato e sostituito dal codice aggiornato.

È inoltre possibile eseguire il backup dell'intero database e codebase di Magento utilizzando il seguente comando:

php <magento_root>/bin/magento setup:backup --code --db
AVVERTENZA

La vendor/magento/data-migration-tool contiene il codice personalizzato. Se non esegui il backup, potresti perdere le personalizzazioni durante l’aggiornamento.

Assicurati che le versioni corrispondano

Le versioni di Data Migration Tool e il software di Magento deve corrispondere esattamente. Ad esempio, Magento 2.1.2 richiede la versione 2.1.2 della Data Migration Tool.

Consulta la sezione Installa Data Migration Tool argomento per scoprire come:

  • Controlla la versione del Magento 2

  • Trova versioni rilasciate Data Migration Tool

  • Controlla la Data Migration Tool version

Aggiornare Data Migration Tool

  1. Accedi al server delle applicazioni come o passa a proprietario del file system.

  2. Passa alla directory principale dell'applicazione.

  3. Immetti il seguente comando:

    composer require magento/data-migration-tool:<version>
    

    dove <version> deve corrispondere alla versione del codebase Magento 2.

    Ad esempio, per la versione 2.1.2, immetti:

    composer require magento/data-migration-tool:2.1.2
    
  4. Attendere il completamento del comando.

In questa pagina