Customers get logged out or lose cart content on Adobe Commerce storefront

This article provides a solution for the issue, where customers get logged out or lose items from the shopping cart on the storefront, after being re-directed back to the Adobe Commerce store from payment or other third-party services (session cookie “gets lost”).

Affected products and versions

Issue

Steps to reproduce:

  1. The customer adds products to cart on storefront and proceeds to checkout.
  2. The customer is redirected to the third-party site for payment/shipping or other information/service.
  3. The customer is redirected back to the store.

Actual result:

Customer redirected to the empty shopping cart or a blank page.

Expected result:

Customer redirected to a success payment page (or other success page), without losing the checkout data and progress.

Cause

The SameSite cookie attribute is set to Lax or not specified (which is treated as set to Lax ). Having SameSite = Lax disables transferring a cookie to external URLs via POST requests.

Solution

To solve the issue, contact the third-party service provider and request their developers update their integrations to configure cookie parameters.

Chrome SameSite update

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