Adobe Commerce 2.4.0 Braintree Virtual Terminal page corrupted

Last update: 2024-02-16
  • Created for:
  • Developer

This article provides a patch for the known Adobe Commerce 2.4.0 issue, where the Braintree Virtual Terminal page does not load the proper UI elements or a proper error message if Braintree is not configured.

Affected products and versions

  • Adobe Commerce on-premises 2.4.0
  • Adobe Commerce on cloud infrastructure 2.4.0

Issue

Scenario 1: Braintree payment method is configured

Steps to reproduce:

In Commerce Admin, go to Sales > Braintree Virtual Terminal . ** **

Expected result:

The Braintree Virtual Terminal page loads with proper UI.

Actual result:

The UI of the Braintree Virtual Terminal page is broken.

Scenario 2: Braintree payment method is configured

Steps to reproduce:

In Commerce Admin, go to Sales > Braintree Virtual Terminal . ** **

Expected result:

The Braintree Virtual Terminal page loads with proper UI and a warning is displayed informing that Braintree is not yet configured.

Actual result:

The UI of the Braintree Virtual Terminal page is broken and no warning is displayed.

Solution

Apply the patch provided in this article.

Patch

The patch is attached to this article. To download it, scroll down to the end of the article and click the file name, or click the following link:

BUNDLE-2670-composer.patch

Compatible Adobe Commerce versions:

The patch was created for:

  • Adobe Commerce on cloud infrastructure 2.4.0
  • Adobe Commerce on-premises 2.4.0

How to apply the patch

See How to apply a composer patch provided by Adobe for instructions.

Attached Files

On this page