Vuelva al formulario de inicio de sesión de administrador de Commerce con el error "La sesión actual ha caducado".

Este artículo ofrece las posibles soluciones para el problema de inicio de sesión del administrador de Commerce, en el que se le redirige de nuevo al formulario de inicio de sesión con el siguiente mensaje de error: "Su sesión actual ha caducado". Las soluciones incluyen comprobar los problemas de configuración de tiempo del servidor y cambiar la configuración de almacenamiento de la sesión.

Ediciones y versiones afectadas:

Todas las versiones y ediciones de Adobe Commerce

Problema

Pasos a seguir:

  1. Vaya a la página de administración de Commerce.
  2. Introduzca sus credenciales de y haga clic en Iniciar sesión.

Resultado esperado:

Ha iniciado sesión en el administrador de Commerce.

Resultado real:

Se le redirigirá de nuevo al formulario de inicio de sesión y se mostrará el siguiente mensaje de error: "Su sesión actual ha caducado".

Causa

El problema puede deberse a dos posibles razones:

  • Se ha corregido un problema con la configuración de tiempo del servidor
  • Se ha corregido un problema con el almacenamiento de sesión

Consulte la siguiente sección para ver las soluciones.

Solución

Comprobar problemas de configuración de tiempo del servidor

Compruebe el registro de sesión creado en la tabla admin_user_session. Si los valores de created_at y/o updated_at son incorrectos, podría deberse al problema con la configuración de la hora del servidor. Pida al administrador del sistema del servidor que lo compruebe. Tenga en cuenta que la hora en la base de datos está configurada en UTC de forma predeterminada.

Cambio del almacenamiento de sesión

Intente cambiar el almacenamiento de la sesión. Use la información del artículo Cómo localizar los archivos de sesión en nuestra documentación para desarrolladores para saber dónde se almacena su sesión y cámbiela editando el archivo app/etc/env.php.

Por ejemplo, para iniciar el almacenamiento de la sesión en el sistema de archivos, cambie la sección 'session' de la siguiente manera:

....
'session' =>
    array (
      'save' => 'files',
),
....

Ejecute el comando bin/magento app:config:import para importar los datos de configuración.

Lectura relacionada

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a