El sistema Magento Order Management (OMS) para Adobe Commerce agota el tiempo de espera

Este artículo proporciona una solución para el problema en el que el sistema Magento Order Management (OMS) para Adobe Commerce no puede registrar el microservicio instalado localmente con MOM mediante ngrok, porque MOM agota el tiempo de espera al intentar la devolución de llamada.

Productos y versiones afectados

  • Adobe Commerce 2.3.1
  • OMS
  • ngrok
WARNING
Descargo de responsabilidad: Adobe Commerce no recomienda ni respalda ninguna herramienta en particular para establecer túneles. Los anteriores son solo sugerencias. Para obtener más información, consulte la documentación de ngrok.

Problema

Pasos a seguir

  1. Instale Adobe Commerce en su entorno local.
  2. Configure ngrok para crear un túnel que exponga el servidor local.
  3. Intente conectarse a OMS.

Resultado esperado

Conexión establecida correctamente.

Resultado real

MCOM parece agotar el tiempo de espera al intentar devolver la llamada a la URL de ngrok.

Causa

Una de las posibles razones del tiempo de espera es que los servidores están ubicados geográficamente demasiado lejos y la conexión tarda demasiado.

Solución

Añada un parámetro que especifique la región al iniciar ngrok. Como el siguiente:

./ngrok http 80 -region eu

La región predeterminada es EE. UU. Ver todos los valores posibles.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a