Notifiche e-mail di Admin 2FA non ricevute

Prodotti e versioni interessati

  • Adobe Commerce su infrastruttura cloud, tutte le versioni

Problema

Hai impostato l’autenticazione a due fattori per migliorare la sicurezza degli accessi amministratore, ma non ricevi l’e-mail con le istruzioni per il completamento della configurazione.

Causa

Se l'e-mail del mittente non è stata configurata correttamente o il dominio non è stato contrassegnato con un'etichetta bianca in SendGrid, è probabile che l'e-mail sia finita nella cartella Spam.

Risoluzione dei problemi

Passaggio 1: verifica la cartella Spam

  1. Se l’e-mail non è stata visualizzata nella cartella Spam, esegui questa query Mysql per verificare che gli indirizzi e-mail siano stati configurati:

    code language-sql
    select * from core_config_data where path like '%trans_email%';
    
    • Se non restituisce alcun risultato, significa che l’indirizzo del mittente non è stato configurato.
    • Se restituisce un risultato, passare al passaggio 2.
  2. Se l’e-mail è apparsa nella cartella Spam, fai clic sul collegamento nell’e-mail. Se il collegamento è scaduto, prova ad accedere di nuovo per ripetere la procedura.

  3. Una volta ottenuto l'accesso, vai a Archivi > Configurazione > Generale > Archivia indirizzi e-mail e configura gli indirizzi e-mail.

Passaggio 2: se/una volta configurati correttamente gli indirizzi e-mail, SSH nell’ambiente ed esegui questo comando:

php -r "mail(<your email address>,<subject>,<content>,'To: <sender email>');"

Controlla la cartella Spam per l’e-mail. Se l'e-mail viene visualizzata, invia un ticket di supporto per richiedere che il dominio sia contrassegnato con un'etichetta bianca in SendGrid.

Lettura correlata

  • SendGrid nella documentazione per gli sviluppatori.
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