FedEx shipping method integration migration from SOAP to RESTful API

This article provides a patch to resolve issues with the FedEx shipping method integration migration from SOAP to RESTful API for Adobe Commerce 2.4.4-p4 - 2.4.6-pX.

FedEx Web Services tracking, Address Validation, and Validate Postal Codes Web Services Definition Languages (WSDLS) will be retired on May 15, 2024. The SOAP based FedEx Web Services is in development containment and has been replaced with FedEx RESTFUL APIs. To learn more, refer to FedEx Web Services.

This change impacts our current FedEx shipping method integration implementation in Adobe Commerce and requires we fix our current implementation and migrate from deprecated SOAP APIs to the latest FedEx RESTFUL APIs.

Beginning on May 15, 2024, Adobe Commerce customers will not be able to use our current FedEx shipping method integration, so Adobe is releasing this hotfix that allows Adobe Commerce 2.4.4+ customers to use the latest FedEx RESTFUL APIs instead of the deprecated SOAP ones.

Affected products and versions

Adobe Commerce on cloud infrastructure and on-premises, and Magento Open Source:

  • 2.4.4-p4
  • 2.4.5
  • 2.4.5-pX
  • 2.4.6
  • 2.4.6-pX

Cause

The FedEx deprecated their SOAP based APIs and replaced them with the RESTful ones instead. Refer to FedEx Web Services.

Solution

Use the following attached patches, depending on your Adobe Commerce/Magento Open Source version:

To resolve the issue in the 2.4.4+, 2.4.5+, and 2.4.6+ versions, you must apply the corresponding patch to your version of Adobe Commerce/Magento Open Source below.

Patch

Use the following attached patches, depending on your Adobe Commerce/Magento Open Source version:

For versions 2.4.4-p4:

For versions 2.4.5, 2.4.5-pX:

For versions 2.4.6, 2.4.6-pX:

How to apply the patch

Unzip the file and see How to apply a composer patch provided by Adobe in our support knowledge base for instructions.

How to tell whether the patches have been applied

Considering that it is not possible to easily check if the issue was patched, you might want to check whether the patch has been successfully applied. This uses (Example: AC-9363) as the patch to check.

You can do this by taking the following steps:

  1. Install the Quality Patches Tool.

  2. Run the command:

    code language-bash
    vendor/bin/magento-patches -n status |grep "9363|Status"
    
  3. You should see output similar to this, where AC-9363 returns the  Applied  status:

    code language-bash
    ║ Id            │ Title                                                        │ Category        │ Origin                 │ Status      │ Details                                          ║ ║ N/A           │ ../m2-hotfixes/AC-9363_USPS_Ground_Advantage_shipping_method_COMPOSER_patch.patch      │ Other           │ Local                  │ Applied     │ Patch type: Custom
    
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a