Adobe Commerce-Zugriffsschlüssel

NOTE
Die Upgrade Compatibility Tool ist nur für Adobe Commerce-Instanzen verfügbar.

Sie müssen Adobe Commerce-Zugriffsschlüssel zum Herunterladen und Verwenden der Upgrade Compatibility Tool. Fügen Sie Ihre Adobe Commerce-Zugriffsschlüssel zu Ihren auth.json -Datei, die sich unter ~/.composer Standardmäßig.

NOTE
Überprüfen Sie Ihre COMPOSER_HOME Umgebungsvariable, um zu sehen, wo die auth.json -Datei befindet.

Die öffentlicher Schlüssel entspricht Benutzername in der Erwägung, privater Schlüssel ist die password:

Beispiel für Adobe Commerce-Zugriffsschlüssel

    "http-basic": {
        "repo.magento.com": {
            "username": "YOUR_MAGENTO_PUBLIC_KEY",
            "password": "YOUR_MAGENTO_PRIVATE_KEY"
        }
    },
NOTE
Wenn Sie Ihre Adobe Commerce-Zugriffsschlüssel, können Sie die Upgrade Compatibility Tool und composer create-project schlägt fehl.

Ausführen composer install in Ihrem Terminal, um Abhängigkeiten zu installieren.

Systemanforderungen

Die Mindestanforderungen für die Verwendung der Upgrade Compatibility Tool in einer Befehlszeilenschnittstelle sind:

Voraussetzungen
Einschränkungen
PHP-Version
>= 7.3
Verfasser
keine bekannten Anforderungen.
Node.js
Node.js-Versionen ^12.22.0, ^14.17.0oder >=16.0.0 (siehe Installieren von Node.js)
Speicherbeschränkungen
Mindestens 2 GB RAM.

Upgrade Compatibility Tool erfordert PCNTL und anderen PHP-Erweiterungen für die Ausführung. Überprüfen Sie die erforderlichen PHP-Erweiterungen mit composer check-platform-reqs command:

# Example output of `composer check-platform-reqs` command for UCT 2.2.6 and PHP 7.4:

$ composer check-platform-reqs
Checking platform requirements for packages in the vendor dir
ext-ctype     *         success provided by symfony/polyfill-ctype
ext-dom       20031129  success
ext-filter    7.4.30    success
ext-json      7.4.30    success
ext-libxml    7.4.30    success
ext-mbstring  *         success provided by symfony/polyfill-mbstring
ext-openssl   7.4.30    success
ext-pcntl     7.4.30    success
ext-pcre      7.4.30    success
ext-phar      7.4.30    success
ext-simplexml 7.4.30    success
ext-tokenizer 7.4.30    success
ext-xml       7.4.30    success
ext-xmlwriter 7.4.30    success
ext-zip       1.15.6    success
php           7.4.30    success

Adobe Commerce wird nur unter Linux-Betriebssystemen unterstützt. Sie können die Upgrade Compatibility Tool in einem Linux-Betriebssystem. Sie müssen nicht die Upgrade Compatibility Tool wo sich Ihre Adobe Commerce-Instanz befindet.

Es ist notwendig, die Upgrade Compatibility Tool , um Zugriff auf den Quellcode der Adobe Commerce-Instanz zu erhalten. Sie können es beispielsweise auf einem Server installieren und auf eine andere Adobe Commerce-Installation verweisen.

Wenn Sie die Upgrade Compatibility Tool Bei einer Adobe Commerce-Instanz mit großen Modulen und Dateien erfordert das Tool möglicherweise eine hohe RAM-Menge (mindestens 2 GB).

Führen Sie die Upgrade Compatibility Tool aus dem Site-Wide Analysis Tool für Adobe Commerce auf Cloud-Infrastruktur Projekte.

recommendation-more-help
83a60e0e-8849-4685-a8cd-c129ecd795ea