Adobe Commerce 2.4.0 Braintree Virtual Terminal-Seite beschädigt

Dieser Artikel enthält einen Patch für das bekannte Adobe Commerce 2.4.0-Problem, bei dem die Braintree Virtual Terminal-Seite die entsprechenden Benutzeroberflächenelemente nicht lädt, oder eine entsprechende Fehlermeldung, wenn Braintree nicht konfiguriert ist.

Betroffene Produkte und Versionen

  • Adobe Commerce vor Ort 2.4.0
  • Adobe Commerce auf Cloud-Infrastruktur 2.4.0

Problem

Szenario 1: Braintree-Zahlungsmethode ist konfiguriert

Zu reproduzierende Schritte:

Navigieren Sie in Commerce Admin zu Vertrieb > Braintree Virtual Terminal . **​ **

Erwartetes Ergebnis:

Die Braintree Virtual Terminal Seite wird mit der richtigen Benutzeroberfläche geladen.

Ergebnis:

Die Benutzeroberfläche der Braintree Virtual Terminal Seite ist kaputt.

Szenario 2: Braintree-Zahlungsmethode ist konfiguriert

Zu reproduzierende Schritte:

Navigieren Sie in Commerce Admin zu Vertrieb > Braintree Virtual Terminal . **​ **

Erwartetes Ergebnis:

Die Braintree Virtual Terminal -Seite mit der richtigen Benutzeroberfläche geladen wird und ein Warnhinweis angezeigt wird, der darüber informiert, dass Braintree noch nicht konfiguriert ist.

Ergebnis:

Die Benutzeroberfläche der Braintree Virtual Terminal -Seite beschädigt ist und keine Warnung angezeigt wird.

Lösung

Wenden Sie den in diesem Artikel bereitgestellten Patch an.

Patch

Der Patch ist an diesen Artikel angehängt. Scrollen Sie zum Herunterladen nach unten zum Ende des Artikels und klicken Sie auf den Dateinamen oder auf den folgenden Link:

BUNDLE-2670-composer.patch

Kompatible Adobe Commerce-Versionen:

Der Patch wurde für erstellt:

  • Adobe Commerce auf Cloud-Infrastruktur 2.4.0
  • Adobe Commerce vor Ort 2.4.0

Anwenden des Pflasters

Siehe Anwenden eines von Adobe bereitgestellten Composer-Patches für Anweisungen.

Attached Files

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a