Fehlerbehebung bei New Relic auf Adobe Commerce in der Cloud-Infrastruktur

Dieser Artikel enthält Ressourcen zur Fehlerbehebung bei New Relic in Adobe Commerce in der Cloud-Infrastruktur.

Problem
Ursache
Ressourcen
Zugriffsprobleme

Projekte in New Relic können nicht angezeigt werden.

Sie melden sich bei New Relic an, können jedoch keine Projekte anzeigen, für die Sie berechtigt sein sollten, darauf zuzugreifen.

In diesen Fällen muss ein Administrator Sie zum Projekt hinzufügen.
Zugriff auf New Relic-Dienste in unserer Wissensdatenbank.
Datenprobleme

Fehlende Daten nach der Installation.

Verwenden Sie das Dienstprogramm New Relic Diagnostics, um die Ursache zu ermitteln. Wenn dies nicht hilfreich ist, sollten Sie sich agentenspezifische Lösungen ansehen. Links zu Artikeln, die diese Lösungen enthalten, befinden sich in der rechten Spalte.

Fehlende Daten können unterschiedliche Ursachen haben. Möglicherweise müssen Sie:

  • Überprüfen Sie, ob der Agent installiert ist.
  • Überprüfen Sie Ihren App-Namen und Ihren Lizenzschlüssel.
  • Starten Sie den Webserver neu.
  • Stellen Sie sicher, dass Ihr System die Kompatibilitätsanforderungen erfüllt.
  • INI-Einstellungen.
Diskrepanz bei Transaktionszeitstempeln. Sie können mit der New Relic-Benutzeroberfläche Schwierigkeiten haben, lange Transaktionen (mehr als 5 Minuten) zu finden. Sie können auch Transaktionen finden, die außerhalb des erwarteten Zeitrahmens angezeigt werden.
In der New Relic-Benutzeroberfläche wird der Zeitpunkt des Transaktionsendes und nicht der Zeitpunkt des Transaktionsbeginns angezeigt.
Um den Anfang der Transaktion mithilfe der New Relic-Benutzeroberfläche zu berechnen, überprüfen Sie die Dauer der Transaktion. Ziehen Sie den Betrag der Dauer vom Zeitstempel (Transaktionsende) ab, der von der Benutzeroberfläche von New Relic bereitgestellt wird.
NerdGraph GraphQL curl Abfragen mit Sonderzeichen wie | und % funktionieren nicht.
Die New Relic-Funktion "Copy to curl"in NerdGraph bietet derzeit keine Möglichkeit, Sonderzeichen wie | und % zu verarbeiten.
Verwenden Sie eine andere API-Bibliothek, um das Problem mit Sonderzeichen zu lösen. Beispiel: GraphQLClient-Bibliothek für GraphQL-API in Python oder Apache.commons nach Java-Sprachaufrufen. Überprüfen Sie Client-Bibliotheken auf GraphQL.
Anzeigeprobleme mit Diagrammen und Dashboards
Beheben Sie fehlende Diagramme, indem Sie New Relic-Domänen zur Zulassungsliste hinzufügen oder die Browsererweiterung deinstallieren, was zu Problemen führt.
New Relic-Dokumentation > Diagramme fehlen oder nicht rendern
Probleme mit PHP-Agenten
Der PHP Agent zeigt nicht die richtige Instanzanzahl an.
Die Anzahl der Instanzen kann in Abhängigkeit von Back-End-Prozessen und -Durchsatz steigen. Unterschiede zwischen Serverwerten können auf Prozesse zurückzuführen sein, die auf einem Server, aber nicht auf dem anderen Server ausgeführt werden.
New Relic-Dokumentation > Fehlerbehebung bei der Anzahl der PHP-Agent-Instanzen
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a