Fehlerbehebung bei New Relic in Adobe Commerce auf Cloud-Infrastruktur

Dieser Artikel enthält Ressourcen zur Fehlerbehebung bei New Relic in Adobe Commerce in Cloud-Infrastrukturen.

Problem
Ursache
Ressourcen
Zugriffsprobleme

Projekte in New Relic werden nicht angezeigt.

Sie melden sich bei New Relic an sehen jedoch keine Projekte, für die Sie über die Berechtigung zum Anzeigen/Zugreifen verfügen.

In diesen Fällen muss Sie ein Administrator bzw. eine Administratorin zum Projekt hinzufügen.
Zugriff auf New Relic- in unserer Support-Wissensdatenbank.
Datenprobleme

Fehlende Daten nach der Installation.

Mit dem New Relic-Diagnosedienstprogramm können Sie die Ursache ermitteln. Wenn dies nicht hilfreich ist, schauen Sie sich die agentenspezifischen Lösungen an. Links zu Artikeln, die diese Lösungen enthalten, finden Sie in der rechten Spalte.

Fehlende Daten können unterschiedliche Ursachen haben. Möglicherweise müssen Sie:

  • Stellen Sie sicher, dass der Agent installiert ist.
  • Überprüfen Sie Ihren App-Namen und Ihren Lizenzschlüssel.
  • Starten Sie den Webserver neu.
  • Stellen Sie sicher, dass Ihr System die Kompatibilitätsanforderungen erfüllt.
  • INI-Einstellungen.
Diskrepanz beim Transaktionszeitstempel. Sie können Schwierigkeiten haben, lange Transaktionen (mehr als 5 Minuten) über die New Relic-Benutzeroberfläche zu finden. Möglicherweise werden auch Transaktionen außerhalb des erwarteten Zeitraums angezeigt.
Die New Relic-Benutzeroberfläche zeigt den Zeitpunkt des Transaktionsendes an, nicht den Zeitpunkt, zu dem die Transaktion begann.
Um den Beginn der Transaktion mithilfe der New Relic-Benutzeroberfläche zu berechnen, überprüfen Sie die Dauer der Transaktion. Ziehen Sie den Dauerbetrag vom Zeitstempel (Transaktionsende) ab, der von der New Relic-Benutzeroberfläche bereitgestellt wird.
NerdGraph GraphQL curl Abfragen mit Sonderzeichen wie | und % funktionieren nicht.
Die New Relic-Funktion „Kopieren in cURL“ in NerdGraph bietet derzeit keine Möglichkeit, Sonderzeichen wie | und % zu verarbeiten.
Verwenden Sie eine andere API-Bibliothek, um das Problem mit Sonderzeichen zu lösen. Beispielsweise die GraphQL-Client-Bibliothek für die GraphQL-API in Python oder Apache.commons nach Java-Sprachaufrufen. Überprüfen Sie Client-Bibliotheken auf GraphQL.
Probleme in Diagrammen und Dashboards anzeigen.
Beheben Sie fehlende Diagramme, indem Sie der Zulassungsliste New Relic-Domains hinzufügen oder die Browser-Erweiterung deinstallieren, was die Probleme verursacht.
New Relic-Dokumentation > Diagramme fehlen oder werden nicht gerendert
Probleme mit PHP-Agenten
Der PHP-Agent zeigt nicht die richtige Anzahl an Instanzen an.
Die Anzahl der Instanzen kann je nach Back-End-Prozessen und Durchsatz steigen. Unterschiede zwischen den Server-Werten können durch Prozesse verursacht werden, die auf einem Server ausgeführt werden, aber nicht auf dem anderen Server.
New Relic-Dokumentation > Fehlerbehebung bei der PHP-Agenteninstanzanzahl
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a