Dieser Artikel enthält Empfehlungen zur Lösung des Problems, dass Venia-Storefront-GraphQL-Abfragen an die Adobe Commerce-Instanz zu Validierungsfehlern führen.
Betroffene Produkte und Versionen
Problem
Venia GraphQL-Abfragen an lokale Adobe Commerce-Standorte oder Adobe Commerce in der Cloud-Infrastruktur führen zu Validierungsfehlern.
Ursache
Einer der Gründe für das Problem kann Venia sein, dessen GraphQL-Abfragen nicht mit dem Schema der verbundenen Adobe Commerce-Instanz synchronisiert sind.
Lösung
Um zu testen, ob Ihre Abfragen aktuell sind, führen Sie den folgenden Befehl im Projektstamm aus:
Daraufhin wird ein Kompatibilitätsbericht angezeigt. Wenn Sie Inkompatibilitäten haben, müssen Sie Ihr PWA Studio oder Ihre Adobe Commerce-Instanz aktualisieren. Überprüfen Sie die Adobe Commerce-Kompatibilitätsmatrix um zu sehen, welche Versionen Sie genau benötigen.
In der folgenden Dokumentation finden Sie Anweisungen zum Upgrade: