Die .csv-Datei der exportierten Produkte wird nicht angezeigt
In diesem Artikel wird das Problem behoben, dass Sie versuchen, Produkte in eine CSV-Datei in Commerce Admin zu exportieren, die Datei jedoch nicht angezeigt wird.
Betroffene Produkte und Versionen
- Adobe Commerce in der Cloud-Infrastruktur, alle unterstützten Versionen.
Problem
Zu reproduzierende Schritte
Voraussetzungen: Die Option Geheimen Schlüssel zu URLs hinzufügen ist auf Ja eingestellt. Die Option wird im Commerce-Admin unter Geschäfte > Konfiguration > Erweitert > Admin > Sicherheit konfiguriert.
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Navigieren Sie im Admin zu "System"> "Datenübertragung"> "Export".
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Auswählen
- Entitätstyp: Produkte
- Dateiformat exportieren: CSV
- Feldeingabe: Lassen Sie die Option deaktiviert.
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Klicken Sie auf Weiter.
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Die folgende Meldung wird angezeigt: "Nachricht wird der Warteschlange hinzugefügt, warten Sie, bis Sie Ihre Datei bald erhalten".
Erwartetes Ergebnis
Die .csv -Datei mit den exportierten Produkten wird in wenigen Minuten im Raster angezeigt.
Tatsächliches Ergebnis
Die .csv -Datei mit den exportierten Produkten wird nicht mehr als 10 Minuten im Raster angezeigt.
Ursache
Ein bekanntes Problem mit der Exportfunktion in der Adobe Commerce-Programmteil-Version 2.3.2.
Lösung
Es gibt zwei mögliche Lösungen für dieses Problem:
- Deaktivieren Sie die Option Geheimen Schlüssel zur URL hinzufügen .
- Führen Sie den Befehl
bin/magento queue:consumers:start exportProcessor
manuell aus und konfigurieren Sie ihn optional für die Ausführung durch Cron.
Weitere Informationen zu beiden Optionen finden Sie in den folgenden Absätzen.
Deaktivieren Sie die Option Geheimen Schlüssel zur URL hinzufügen .
- Navigieren Sie im Admin zu "Stores"> "Konfiguration"> "Erweitert"> "Admin"> "Sicherheit".
- Setzen Sie die Option Geheimen Schlüssel zu URLs hinzufügen auf Nein.
- Klicken Sie auf Konfiguration speichern.
- Cache unter System > Tools > Cache-Verwaltung bereinigen oder durch Ausführen von
bash bin/magento cache:clean
oder im Admin.
Führen Sie den Exportbefehl manuell aus und fügen Sie ihn optional als Cron-Auftrag hinzu
Um die Exportdatei zu erhalten, führen Sie den Befehl bin/magento queue:consumers:start exportProcessor
aus. Nach der Ausführung sollte die Datei im Raster angezeigt werden.
Um den Prozess optional als Cron-Auftrag hinzuzufügen, müssen Sie die Variable CRON_CONSUMERS
zur Datei .magento.env.yaml
hinzufügen.
Prozess als Cron-Auftrag hinzufügen (optional)
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Stellen Sie sicher, dass Ihr Cron eingerichtet und konfiguriert ist. Weitere Informationen finden Sie unter Einrichten von Cron-Aufträgen .
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Führen Sie den folgenden Befehl aus, um eine Liste der Verbraucher in der Nachrichtenwarteschlange zurückzugeben:
./bin/magento queue:consumers:list
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Fügen Sie Ihrer
.magento.env.yaml
-Datei im Stammverzeichnis der Anwendung Folgendes hinzu und schließen Sie die Verbraucher ein, die Sie hinzufügen möchten. Hier ist beispielsweise der für die Exportverarbeitung erforderliche Verbraucher:code language-yaml stage: deploy: CRON_CONSUMERS_RUNNER: cron_run: true max_messages: 1000 consumers: - exportProcessor
Pushen Sie dann diese aktualisierte Datei und stellen Sie Ihre Umgebung erneut bereit. Weitere Informationen finden Sie unter Hinzufügen benutzerdefinierter Cron-Aufträge zu Ihrem Projekt in unserer Entwicklerdokumentation.
.magento.env.yaml
" für Ihre Umgebung nicht finden können und der Eindruck haben, dass sie gelöscht wurde, müssen Sie eine neue ".magento.env.yaml
"erstellen. Es kann anfangs leer sein. Sie können dort bei Bedarf Informationen hinzufügen. Verweisen Sie in unserer Entwicklerdokumentation auf die folgenden Artikel: Umgebungsvariablen für die Bereitstellung konfigurieren und Umgebungsvariablen ..magento.app.yaml
hinzufügen können. Wenn diese Funktion nicht aktiviert ist, erstellen Sie ein Support-Ticket, damit der Auftrag für Sie hinzugefügt wird.