Exportierte .csv-Produktdatei wird nicht angezeigt

Dieser Artikel bietet eine Lösung für den Fall, dass der Export des gewünschten Entitätstyps in eine CSV-Datei in der Commerce Admin dazu führt, dass die Datei nicht angezeigt wird.

Betroffene Produkte und Versionen

Problem

Schritte zur Reproduktion

Voraussetzungen: Die Option Geheimen Schlüssel zu URLs hinzufügen ist auf "". Die Option wird im Commerce Admin unter Stores > Configuration > Advanced > Admin > Security konfiguriert.

  1. Navigieren Sie in der Admin zu System > Datenübertragung > Exportieren.

    magento_export_products_2.3.4.png

  2. Auswählen

    • Entitätstyp: Die zu exportierende Entität
    • Dateiformat exportieren: CSV
    • Feldgehäuse: nicht markieren.
  3. Klicken Sie Weiter.

  4. Die folgende Meldung wird angezeigt: „Nachricht wird der Warteschlange hinzugefügt, bitte warten, bis die Datei bald verfügbar ist“.

Erwartetes Ergebnis

Die CSV-Datei, die den exportierten gewünschten Entitätstyp enthält, wird innerhalb weniger Minuten im Raster angezeigt.

Tatsächliches Ergebnis

Die CSV-Datei, die den exportierten gewünschten Entitätstyp enthält, wird nicht in 10 Minuten oder länger im Raster angezeigt.

Ursache

Ein bekanntes Problem mit der Exportfunktion in der Adobe Commerce-Programmteilversion 2.3.2.

Lösung

Es gibt zwei mögliche Lösungen für dieses Problem:

  • Deaktivieren Sie die Option Geheimen Schlüssel zur URL hinzufügen .
  • Führen Sie den bin/magento queue:consumers:start exportProcessor Befehl manuell aus und konfigurieren Sie ihn optional so, dass er von cron ausgeführt wird.

Weitere Informationen zu beiden Optionen finden Sie in den folgenden Absätzen.

Deaktivieren Sie die Option Geheimen Schlüssel zur URL hinzufügen .

  1. Navigieren Sie in Admin zu Stores > Konfiguration > Erweitert > Admin > Sicherheit.
  2. Setzen Sie die Geheimschlüssel zu URLs hinzufügen auf Nein.
  3. Klicken Sie Konfiguration speichern.
  4. Bereinigen Sie den Cache unter System > Tools > Cache-Verwaltung oder indem Sie Folgendes ausführen bash bin/magento cache:clean oder in der Admin.

Führen Sie den Exportbefehl manuell aus und fügen Sie ihn optional als Cron-Auftrag hinzu

Um die Exportdatei abzurufen, führen Sie den bin/magento queue:consumers:start exportProcessor Befehl aus. Danach sollte die Datei im Raster angezeigt werden.

Um den Prozess optional als Cron-Auftrag hinzuzufügen, müssen Sie die CRON_CONSUMERS Variable zur .magento.env.yaml-Datei hinzufügen.

Prozess als Cron-Auftrag hinzufügen (optional)

  1. Stellen Sie sicher, dass Ihr Cron eingerichtet und konfiguriert ist. Weitere finden Sie unter „EinrichtenCron-Aufträgen“.

  2. Führen Sie den folgenden Befehl aus, um eine Liste der Nachrichtenwarteschlangen-Verbraucher zurückzugeben: ./bin/magento queue:consumers:list

  3. Fügen Sie Ihrer .magento.env.yaml-Datei im Stammverzeichnis der Anwendung Folgendes hinzu und schließen Sie die Verbraucher ein, die Sie hinzufügen möchten. Hier finden Sie beispielsweise den Verbraucher, der für die Exportverarbeitung erforderlich ist:

    code language-yaml
    stage:
        deploy:
            CRON_CONSUMERS_RUNNER:
                cron_run: true
                max_messages: 1000
                consumers:
                    - exportProcessor
    

    Pushen Sie dann diese aktualisierte Datei und stellen Sie Ihre Umgebung erneut bereit. Verweisen Sie auch Benutzerdefinierte Cron-Aufträge zu Ihrem Projekt hinzufügen in unserer Entwicklerdokumentation.

NOTE
Wenn Sie die .magento.env.yaml-Datei für Ihre Umgebung nicht finden können und der Meinung sind, dass sie gelöscht wurde, müssen Sie eine neue .magento.env.yaml erstellen. Möglicherweise ist es zunächst leer. Sie können dort nach Bedarf weitere Informationen hinzufügen. Verweisen Sie auf die folgenden Artikel „Konfigurieren von Umgebungsvariablen für" und Umgebungsvariablen in Ihrer Entwicklerdokumentation.
TIP
YAML-Dateien wird zwischen Groß- und Kleinschreibung unterschieden und es werden keine Registerkarten zugelassen. Achten Sie darauf, in der gesamten Datei ".magento.env.yaml“ einen konsistenten Einzug zu verwenden. Andernfalls funktioniert Ihre Konfiguration möglicherweise nicht wie erwartet. Die Beispiele in der Dokumentation und in der Beispieldatei verwenden eine Einrückung mit zwei Leerzeichen. Verwenden Sie den Befehl ECE-Tools validate , um Ihre Konfiguration zu überprüfen.
NOTE
In Adobe Commerce in Cloud Infrastructure Pro-Projekten muss die Funktion automatische Krone in Ihrer Adobe Commerce in der Cloud-Infrastruktur aktiviert sein, bevor Sie mithilfe von .magento.app.yaml benutzerdefinierte Cron-Aufträge zu Staging- und Produktionsumgebungen hinzufügen können. Wenn diese Funktion nicht aktiviert ist erstellen Sie ein Support-Ticket, damit der Auftrag für Sie hinzugefügt wird.
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