Die .csv-Datei der exportierten Produkte wird nicht angezeigt
In diesem Artikel wird das Problem behoben, dass Sie versuchen, Produkte in eine CSV-Datei in Commerce Admin zu exportieren, die Datei jedoch nicht angezeigt wird.
Betroffene Produkte und Versionen
- Adobe Commerce in der Cloud-Infrastruktur, alle unterstützte Versionen.
Problem
Zu reproduzierende Schritte
Voraussetzungen: Die Geheimen Schlüssel zu URLs hinzufügen ist auf Ja. Die Option wird im Commerce Admin unter Stores > Konfiguration > Erweitert > Admin > Sicherheit.
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Navigieren Sie im Admin zu System > Datenübertragung > Export.
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Auswählen
- Entitätstyp: Produkte
- Dateiformat exportieren: CSV
- Feldumgebung: Lassen Sie die Option deaktiviert.
-
Klicks Weiter.
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Die folgende Meldung wird angezeigt: "Meldung wird der Warteschlange hinzugefügt, warten Sie, bis Sie Ihre Datei bald erhalten.".
Erwartetes Ergebnis
Die .csv -Datei mit den exportierten Produkten wird in wenigen Minuten im Raster angezeigt.
Tatsächliches Ergebnis
Die .csv -Datei mit den exportierten Produkten wird nicht mehr als 10 Minuten im Raster angezeigt.
Ursache
Ein bekanntes Problem mit der Exportfunktion in der Adobe Commerce-Programmteil-Version 2.3.2.
Lösung
Es gibt zwei mögliche Lösungen für dieses Problem:
- Deaktivieren Sie die Option Geheimen Schlüssel zur URL hinzufügen .
- Führen Sie die
bin/magento queue:consumers:start exportProcessor
-Befehl manuell ausführen und optional konfigurieren, dass sie von Cron ausgeführt werden.
Weitere Informationen zu beiden Optionen finden Sie in den folgenden Absätzen.
Deaktivieren Sie die Option Geheimen Schlüssel zur URL hinzufügen .
- Navigieren Sie im Admin zu Stores > Konfiguration > Erweitert > Admin > Sicherheit.
- Legen Sie die Geheimen Schlüssel zu URLs hinzufügen -Option Anzahl
- Klicks Konfiguration speichern.
- Cache unter leeren System > Instrumente > Cacheverwaltung oder durch Ausführen
bash bin/magento cache:clean
oder im Admin.
Führen Sie den Exportbefehl manuell aus und fügen Sie ihn optional als Cron-Auftrag hinzu
Führen Sie zum Abrufen der Exportdatei den bin/magento queue:consumers:start exportProcessor
Befehl. Nach der Ausführung sollte die Datei im Raster angezeigt werden.
Um den Prozess optional als Cron-Auftrag hinzuzufügen, müssen Sie die CRON_CONSUMERS
in die .magento.env.yaml
-Datei.
Prozess als Cron-Auftrag hinzufügen (optional)
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Stellen Sie sicher, dass Ihr Cron eingerichtet und konfiguriert ist. Siehe Einrichten von Cron-Aufträgen für Details.
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Führen Sie den folgenden Befehl aus, um eine Liste der Verbraucher in der Nachrichtenwarteschlange zurückzugeben:
./bin/magento queue:consumers:list
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Fügen Sie Folgendes zu Ihrer
.magento.env.yaml
im Stammverzeichnis der Anwendung und schließen Sie die Verbraucher ein, die Sie hinzufügen möchten. Hier ist beispielsweise der für die Exportverarbeitung erforderliche Verbraucher:code language-yaml stage: deploy: CRON_CONSUMERS_RUNNER: cron_run: true max_messages: 1000 consumers: - exportProcessor
Pushen Sie dann diese aktualisierte Datei und stellen Sie Ihre Umgebung erneut bereit. Referenz Hinzufügen benutzerdefinierter Cron-Aufträge zu Ihrem Projekt in unserer Entwicklerdokumentation.
.magento.env.yaml
-Datei für Ihre Umgebung erstellen und Sie glauben, dass sie gelöscht wurde, müssen Sie eine neue .magento.env.yaml
. Es kann anfangs leer sein. Sie können dort bei Bedarf Informationen hinzufügen. Verweisen Sie auf die folgenden Artikel: Umgebungsvariablen für die Bereitstellung konfigurieren und Umgebungsvariablen in unserer Entwicklerdokumentation..magento.app.yaml
. Wenn diese Funktion nicht aktiviert ist, Support-Ticket erstellen, damit der Auftrag für Sie hinzugefügt wird.