Cache aktivieren, um Leistungseinbußen zu vermeiden

In diesem Artikel wird erläutert, wie Sie ein langsames Site-Problem beheben können, das durch die Deaktivierung bestimmter Adobe Commerce-Cache-Typen verursacht wird.

Betroffene Produkte und Versionen

  • Adobe Commerce auf Cloud-Infrastruktur 2.2.x, 2.3.x
  • Adobe Commerce On-Premises 2.2.x, 2.3.x

Problem

Man bemerkt Leistungseinbußen. Beispielsweise wird die Checkout-Seite langsam geladen oder der Apdex-Wert sinkt in New Relic.

Ursache

Ein Grund für Leistungseinbußen können bestimmte Adobe Commerce-Cache-Typen sein, die deaktiviert sind.

Lösung

  1. Überprüfen Sie zunächst den Status Ihres Adobe Commerce-Caches, um festzustellen, ob dies das Problem ist. Dazu Sie „SSH“ in Ihre Umgebungund führen den folgenden Befehl aus:

    code language-bash
    php bin/magento cache:status
    

    Dadurch wird der Status jedes Cache-Typs angezeigt („0“ für deaktiviert, „1“ für aktiviert). Oder Sie erhalten diese Informationen in der app/etc/env.php.

  2. Untersuchen Sie die deaktivierten Cache-Typen. Alle Adobe Commerce-Cache-Typen sollten aktiviert werden, es sei denn, Sie haben eine alternative Anleitung von Adobe erhalten. Erweiterungen von Drittanbietern dürfen nicht die Deaktivierung des Adobe Commerce-Caches erfordern.

  3. Wenn die Untersuchung bestätigt, dass einige Cache-Typen versehentlich deaktiviert sind, aktivieren Sie sie, indem Sie den folgenden Befehl für jeden Cache-Typ ausführen: php bin/magento cache:enable <your_disabled_cache_type>

Wenn es Bedenken und/oder Fragen dazu gibt, ob ein bestimmter Adobe Commerce-Cache-Typ deaktiviert werden kann oder sollte, wenden Sie sich an den Adobe Commerce-Support und fragen Sie nach Empfehlungen.

Verwandtes Lesen

Adobe Commerce-Cache-Dokumentation in unserer Entwicklerdokumentation:

Weitere mögliche Gründe für Leistungsprobleme und Lösungen für sie:

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