Suchmaschine kann nicht mit Commerce Admin geändert werden (Suchmaschinenmenü ist nicht zugänglich)
Warnung: Die MySQL-Katalogsuchmaschine wird in Adobe Commerce 2.4.0 entfernt. Vor der Installation von Version 2.4.0 muss der Elasticsearch-Host eingerichtet und konfiguriert sein.
Siehe:
Installieren und Konfigurieren von Elasticsearch.
Installieren und Konfigurieren von OpenSearch
Installieren und Konfigurieren der Live Search
Dieser Artikel bietet eine Lösung, mit der Sie die Adobe Commerce-Suchmaschine mithilfe der Commerce-Admin ändern können, wenn das Feld Suchmaschine nicht angezeigt wird oder das Kontrollkästchen Systemwert verwenden ausgegraut ist und nicht zugänglich ist.
Beschreibung
Umgebung
-
Adobe Commerce On-Premise: 2.4.x
-
Adobe Commerce auf Cloud-Infrastruktur:
- Version: 2.4.x
- Starter- und Pro-Plan-Architektur
-
MySQL, Elasticsearch, OpenSearch, Live Search: alle unterstützten Versionen
Ändern der Suchmaschine mit der Admin-Funktion (Schritte)
-
Melden Sie sich bei Admin als Administrator an.
-
Klicken Sie links in der Seitenleiste Admin auf Stores.
-
Wählen unter „Einstellungen die Option Konfiguration aus.
-
Navigieren Sie zum Bedienfeld links unter Katalog und wählen Sie Katalog aus.
-
Erweitern Sie den Abschnitt Katalogsuche.
-
Wechseln Sie zum Feld Suchmaschine und entfernen Sie die Auswahl aus dem Systemwert verwenden Kontrollkästchen.
-
Klicken Sie auf Suchmaschine und wählen Sie eine der verfügbaren Optionen wie unten dargestellt.
-
Klicken oben rechts auf Seite auf „Konfiguration speichern“.
Probleme mit Adobe Commerce On-Premise
Problem 1: Das Suchmaschinenfeld wird nicht angezeigt
Beim Zugriff auf den Katalogsuche wird das Menü Suchmaschine überhaupt nicht angezeigt.
Ursache: Store-Ansicht ist keine Standardkonfiguration
Die Store-Ansicht für den Administrator wurde auf einen anderen Wert als "".
Die Suchmaschine ist eine globale Konfiguration, die auf Anwendungsebene festgelegt wird, nicht auf dem Store-Bereich. Stores in einer Adobe Commerce-Anwendung können keine anderen Suchmaschinen verwenden.
Problem 2: Die Option „Systemwert verwenden“ kann nicht deaktiviert werden
Wenn Sie auf den Abschnitt Katalogsuche des Admin-Bereichs zugreifen, ist das Kontrollkästchen Systemwert verwenden ausgegraut, sodass Sie die Auswahl nicht aus dem Kontrollkästchen entfernen können, um die Suchmaschine später zu ändern.
Ursache
Die Standard-Suchmaschine wurde auf Anwendungskonfigurationsebene in den app/etc/env.php
- oder app/etc/config.php
-Dateien konfiguriert und kann daher nicht mit der Administratorin bzw. dem Administrator geändert werden.
Beispiel für den Abschnitt mit der standardmäßigen Suchmaschinenkonfiguration:
'system'=>
array (
'default'=>
array (
'catalog'=>
array (
'search'=>
array (
'engine'=>'mysql',
),
),
),
),
Auflösung
Problem 1: Das Suchmaschinenfeld wird nicht angezeigt
Lösung: Festlegen der Store-Ansicht auf die Standardkonfiguration
-
Melden Sie sich bei Admin als Administrator an.
-
Klicken Sie links in der Seitenleiste Admin auf Stores.
-
Navigieren Sie zu Einstellungen und wählen Sie Konfiguration aus.
-
Klicken Sie in der oberen linken Ecke auf den Selektor Store-Ansicht und wählen Sie Standardkonfiguration.
-
Klicken Sie Bestätigungsdialogfeld auf OK“, um die Änderungen der Store-Ansicht zu genehmigen.
Verwandte Dokumentation: Ändern desin unserem Benutzerhandbuch.
Problem 2: Die Option „Systemwert verwenden“ kann nicht deaktiviert werden
Lösung
Entfernen Sie den Abschnitt mit der standardmäßigen Suchmaschinenkonfiguration aus den app/etc/env.php
- oder app/etc/config.php
.
Verwandte Artikel in unserer Entwicklerdokumentation
Adobe Commerce-Konfigurationsdateien im Adobe Commerce-Konfigurationshandbuch
Adobe Commerce auf Cloud-Infrastruktur
Ein Wechsel zwischen Suchmaschinen mit dem Admin-Service ist in Adobe Commerce in der Cloud-Infrastruktur aufgrund der Art und Weise, wie die Cloud-Infrastruktur organisiert wurde, nicht verfügbar.
Während des Bereitstellungsprozesses überprüfen die Adobe Commerce-Bereitstellungsskripte für die Cloud-Infrastruktur, ob Elasticsearch in der MAGENTO_CLOUD_RELATIONSHIPS
deklariert wurde. Wenn Elasticsearch angegeben wird, wird es als aktive Suchmaschine ausgewählt und automatisch konfiguriert. Die MySQL-Suchmaschine kann in Admin nicht mehr aufgerufen werden. Wenn die Elasticsearch-Beziehung nicht deklariert wurde, wird MySQL auf active gesetzt und Elasticsearch wird unzugänglich.
Es wird nicht empfohlen, die app/etc/env.php
- oder app/etc/config.php
-Konfigurationsdateien direkt in Ihrer Cloud-Umgebung zu bearbeiten. Daher ist es für Ihr Cloud-Projekt nicht sinnvoll, diese Dateien zu ändern, damit die Elasticsearch-Engine in der Admin angezeigt wird (die Lösung, die wir im vorherigen Abschnitt empfehlen).
Ändern der Suchmaschine in Staging- und Produktionsumgebungen
Bevor Sie die Suchmaschine in Ihren Staging- und Produktionsumgebungen von MySQL zu Elasticsearch wechseln, stellen Sie sicher, dass Sie zuvor ein Support-Ticket gesendet die Aktivierung von Elasticsearch in der Umgebung angefordert haben und das Ticket erfolgreich gelöst wurde.
Um die in Ihren Staging- und Produktionsumgebungen verwendete Suchmaschine zu ändern, ändern Sie die Umgebungsvariable SEARCH_CONFIGURATION
in Ihrer .magento.env.yaml
-Datei in Ihrer lokalen Umgebung und übertragen Sie dann Änderungen an die Integrations- und Staging-/Produktionsumgebungen, damit die Änderungen wirksam werden.
Wenn Sie zu Elasticsearch 7 wechseln, könnte die SEARCH_CONFIGURATION
Variable in der resultierenden .magento.env.yaml
wie folgt aussehen:
stage:
deploy:
SEARCH_CONFIGURATION:
engine: elasticsearch7
elasticsearch_server_hostname: hostname
elasticsearch_server_port: '12345'
elasticsearch_index_prefix: magento
elasticsearch_server_timeout: '15'
Wenn Sie zu OpenSearch (in 2.4.6 und höher) wechseln könnte die SEARCH_CONFIGURATION
Variable in der resultierenden .magento.env.yaml
wie folgt aussehen:
stage:
deploy:
SEARCH_CONFIGURATION:
engine: opensearch
elasticsearch_server_hostname: hostname
elasticsearch_server_port: '12345'
elasticsearch_index_prefix: magento
elasticsearch_server_timeout: '15'
Wenn Sie zur Live Search wechseln könnte die SEARCH_CONFIGURATION
Variable in der resultierenden .magento.env.yaml
wie folgt aussehen:
stage:
deploy:
SEARCH_CONFIGURATION:
engine: livesearch
Verwandte Dokumentation
Support-Wissensdatenbank
Dokumentation für Entwickelnde
- Einrichten des Elasticsearch-Service
- Erstellen und Bereitstellen (Dokumentation zur
.magento.env.yaml
-Konfigurationsdatei) - Variablen bereitstellen (Abschnitt SEARCH_CONFIGURATION)
- Dienste (Dokumentation zur
.magento/services.yaml
-Konfigurationsdatei) - Live-Suche