DokumentationCommerceCommerce-Wissensdatenbank

Nur PaaS

MySQL-Server ist verschwunden​ Fehler in Adobe Commerce in der Cloud

Letzte Aktualisierung: 5. Mai 2025
  • Themen:
  • Cloud

Erstellt für:

  • Entwickler

In diesem Artikel wird die Lösung des Problems beschrieben, dass Sie die Fehlermeldung "SQL Server ist verschwunden " in der cron.log-Datei erhalten. Es können eine Reihe von Symptomen auftreten, darunter Probleme beim Importieren von Bilddateien oder Bereitstellungsfehler.

Betroffene Produkte und Versionen

  • Adobe Commerce auf Cloud-Infrastruktur, alle unterstützten Versionen.

Problem

Sie erhalten die Fehlermeldung "SQL Server ist " in der cron.log.

Schritte zur Reproduktion

Importieren von Dateien und Trigger einer -Bereitstellung.

Erwartetes Ergebnis

Erfolgreiche Bereitstellung.

Tatsächliches Ergebnis

Fehlermeldung in cron.log :“ SQLSTATE[HY000] [2006] Der MySQL-Server wurde entfernt at/app/AAAAAAAAA/vendor/magento/zendframework1/library/Zend/Db/Adapter/Pdo/Abstract.php:144“

Ursache

Der default_socket_timeout ist zu niedrig eingestellt. Dies wird durch die Einstellung default_socket_timeout verursacht. Wenn PHP innerhalb dieses Zeitraums nichts von der MySQL-Datenbank erhält, geht es davon aus, dass diese getrennt ist und gibt den Fehler aus.

Lösung

  1. Überprüfen Sie den aktuellen Timeout-Zeitraum für default_socket_timeout, indem Sie in der CLI ausführen: php -i |grep default_socket_timeout
  2. Erhöhen Sie die Variable default_socket_timeout je nach Zeitüberschreitungseinstellung auf die erwartete längstmögliche Laufzeit in der /etc/platform/<project_name>/php.ini. Es wird empfohlen, zwischen 10 und 15 Minuten einzustellen.
  3. Übertragen Sie sie an GIT und stellen Sie sie erneut bereit.

Verwandtes Lesen

  • Datenbank-Upload verliert Verbindung zu MySQL
  • Best Practices für Datenbanken für Adobe Commerce in der Cloud-Infrastruktur
  • Häufigste Datenbankprobleme in Adobe Commerce auf Cloud-Infrastrukturen
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a