[AEM Assets]{class="badge positive" title="適用於AEM Assets)。"}

管理影像預設集 managing-image-presets

影像預設集​是預先定義、可重複使用的調整大小和格式命令集合,可讓​ Adobe Experience Manager (AEM) Assets ​動態傳送影像。 每個影像預設集都可控制不同大小、不同格式的影像傳送,以及動態產生的影像屬性,例如色域、壓縮品質和解析度。 這表示單一主要資產可以許多最佳化的變數傳送,而不需要維護個別的來源檔案。

影像預設集包含的內容

建立影像預設集時,您可以定義控制影像產生和傳送方式的引數。 每個預設集都指定:

  • 傳遞大小 — 提供影像供檢視時使用的尺寸。
  • 格式化命令 — 可最佳化影像外觀以顯示內容的設定。

這些格式指令可確保每當傳送影像以進行檢視時,影像的外觀都會最佳化,因此每個轉譯在出現該轉譯的內容中看起來都是一致的,且可隨時顯示。

使用預設集匯出Assets

管理員可以專門為匯出資產建立預設集。 然後,使用者在匯出影像時選擇預設集,該預設集會將影像重新格式化為管理員定義的規格。 因此,匯出的資產會符合一致且由中央管理的標準,而不需要每位使用者手動設定格式。

有回應的影像預設集和色域

您也可以建立​ 回應式 ​影像預設集。 當您將回應式影像預設集套用至資產時,資產會套用至檢視資產的裝置或熒幕大小。 這種回應式行為有助於將適當大小的影像提供給桌上型電腦、平板電腦和行動裝置,進而提升各種檢視環境的載入效能和視覺品質。

影像預設集支援多個色域。 除了​ RGB ​或​ 灰色 ​之外,您也可以設定影像預設集,以在色域中使用​CMYK (青色、洋紅色、黃色、金鑰/黑色),以支援列印導向和色彩管理的傳遞工作流程。

本節說明如何建立、修改和一般管理影像預設集。 您隨時都可以將「影像預設集」套用至影像。 請參閱套用影像預設集。

NOTE
智慧型影像可與您現有的影像預設集搭配使用,並在最後毫秒的傳送中使用智慧型功能,根據瀏覽器或網路連線速度進一步縮小影像檔案大小。 如需詳細資訊,請參閱智慧型影像。

瞭解影像預設集 understanding-image-presets

影像預設集​是預先定義、可重複使用的大小調整與格式命令集合,以名稱儲存,運作方式與巨集非常類似。 每個預設集都儲存傳送影像所需的精確尺寸、格式和壓縮設定,允許​ Experience Manager ​隨選產生來源影像的正確最佳化版本,而不需要針對每個大小和裝置個別設定檔案。

影像預設集如何運作

假設是常見的情況:網站要求每個產品影像在案頭和行動傳送時,都必須以不同大小、格式和壓縮率顯示。 由於現代網站提供多種熒幕大小和裝置型別的影像,因此這類多格式傳送是回應式網頁體驗的例行需求。

若要處理這個問題,管理員會建立兩個影像預設集:

  • Enlarge — 以​ 500 x 500畫素 ​顯示影像,適合案頭傳遞。
  • Thumbnail — 以​ 150 x 150畫素 ​顯示影像,適合行動傳送。

當對大小為Enlarge或Thumbnail的影像提出要求時,Experience Manager​會找出相符的​ 影像預設集 ​定義。 然後它會動態產生符合該預設集中定義之大小和格式規格的影像。 因此,單一來源影像可以多個最佳化表單傳送,而不需要維護重複資產。

維持任何大小的影像品質

在動態傳送期間縮小影像大小會導致其失去銳利度和細節。 為了應付這個問題,每個影像預設集都包含格式化控制項,當影像以特定大小傳送時,這些控制項會最佳化影像。 這可確保傳送的輸出保持銳利而清晰,因為預設集會針對目標尺寸套用適當的銳利化與格式,而非只是縮放來源。 這些控制項可讓您的影像在存取您的網站或應用程式時保持清晰易讀。

建立影像預設集

管理員可以建立影像預設集。 管理員可以從頭開始建立預設集,或是複製現有預設集,然後以新名稱儲存,重複使用已建立的設定作為起點。

管理影像預設集 managing-image-presets-1

您可以從「工具」主控台的​Assets > 影像預設集​區域管理Experience Manager中的影像預設集。 若要到達此位置,請依照下列步驟操作:

  1. 選取​ Experience Manager標誌 ​以開啟全域導覽主控台。
  2. 選取​ 工具 ​圖示。
  3. 導覽至​Assets > 影像預設集。

65tools-assets-imagepresets

您可以從此影像預設集區域建立、編輯及組織預設集,以控制資產的演算及傳送方式。

NOTE
預覽或傳遞資產時,您建立的任何影像預設集也可作為​ 動態轉譯 ​使用。 這表示定義一次的預設集可在預覽和傳送期間直接重複使用,而不需每次重新定義轉譯設定。
您​ 不 ​需要手動發佈影像預設集,因為影像預設集是​自動發佈。 因此,新建立的預設集將可供傳送,而無需單獨的發佈動作。
請參閱發佈影像預設集。
NOTE
當您在資產的詳細資料檢視中選取​ 轉譯 ​時,系統會顯示各種轉譯。 您可以增加或減少顯示的影像預設集數目,讓您量身打造詳細資料檢視,以僅顯示您需要的轉譯。 請參閱增加顯示的影像預設集數目。

影像預設集與轉譯的相關性 how-image-presets-relate-to-renditions

影像預設集​定義Dynamic Media在要求時傳遞影像的方式,控制一般使用者收到的視覺輸出。 每個預設集都指定一組顯示引數,包括:

  • 調整大小 — 傳送影像的目標寬度、高度或解析度
  • 格式 — 用於傳遞的輸出檔案格式
  • 壓縮 — 套用至影像的品質和檔案大小權衡
  • 其他顯示引數 — 控制最終影像顯示方式的其他設定

轉譯​是資產的已處理版本,在Dynamic Media擷取並處理該資產時產生。 轉譯是傳遞所依賴的基本影像資料。

影像預設集本身不會產生轉譯。 這項區分很重要:預設集是一組傳遞指示,而不是影像資料的來源。 預設集而是仰賴Dynamic Media在處理資產時建立的轉譯。 因此,預設集會在現有轉譯上方,套用其大小、格式和壓縮規則,以產生傳送的影像。

由於轉譯是在資產處理期間建立,而非透過預設集,因此存在合適的轉譯是預設集傳送預期輸出的先決條件。 在實務中,這表示資產處理會先建立可用的影像資料,接著影像預設集就會決定資料在傳送時的呈現方式。

AEM as a Cloud Service中的轉譯產生 rendition-generation-in-aemaacs

在Adobe Experience Manager (AEM) as a Cloud Service中,AEM會使用​資產微服務 (雲端原生、可擴充的處理功能)來產生轉譯。 數位資產管理(DAM)更新資產工作流程無法在Cloud Service中進行自訂,因為轉譯處理是由受管理的微服務層處理,而非由可編輯的工作流程模型處理。

重要考量事項包括:

  • 轉譯會在​ 上傳時間 ​產生,這表示處理作業會在每個資產進入系統時自動進行。
  • 對​ 處理設定檔 ​的變更只會套用至新上傳的資產。 因此,如果需要新的轉譯,則必須重新處理現有資產,因為設定檔變更不會回溯為存放庫中已經存在的內容重新產生轉譯。
  • AEM as a Cloud Service不支援自訂工作流程模型以產生轉譯;轉譯控制完全透過處理設定檔達成。

影像預設集​參考傳遞時可用的轉譯,以提供動態、隨選影像變化。 因此,在設定或使用影像預設集之前,請確定存在所需的轉譯,因為影像預設集無法傳遞尚未產生的轉譯。

若要控制產生哪些轉譯:

  1. 建立或編輯​處理設定檔。
  2. 設定所需的轉譯定義,指定每個轉譯必須產生的格式、尺寸及輸出設定。
  3. 將處理設定檔套用至適當的資料夾,以便該位置的所有資產繼承定義的轉譯設定。

當資產上傳到已套用處理設定檔的資料夾時,資產微服務會自動產生定義的轉譯。 此自動化可確保資料夾中的轉譯輸出一致,無需手動干預,並且這表示將資產組織到具有正確處理設定檔的資料夾中,是控制AEM as a Cloud Service中轉譯產生的主要機制。

增加或減少顯示的影像預設集數目 increasing-or-decreasing-the-number-of-image-presets-that-display

預覽資產時,您建立的影像預設集可用作​動態轉譯。 動態轉譯是資產的即時變數(從預設設定(例如大小、格式或壓縮)產生),而不是單獨儲存的檔案。 當您從​ 詳細資料檢視>轉譯 ​檢視資產時,Experience Manager會顯示這些動態轉譯。 您可以增加或減少顯示的轉譯限制,這在您維護大型預設集資料庫並希望一次看到更多預設集或您偏好較短且更聚焦的清單時非常有用。

依預設,Experience Manager最多可顯示​15個影像預設集。 調整​ limit ​屬性會提高或降低此最大值,讓轉譯清單符合工作流程所需的預設集數目。

若要增加或減少顯示的影像預設集數目:

  1. 導覽至CRXDE Lite (https://localhost:4502/crx/de)。

  2. 導覽至影像預設集,清單節點位於/libs/dam/gui/coral/content/commons/sidepanels/imagepresetsdetail/imgagepresetslist

    increasedecreasethenumberofimagepresetsthatdisplay

  3. 在​ limit ​屬性中,將預設設定為​ 15 ​的​ 值 ​變更為所要的數字。

  4. 導覽至/libs/dam/gui/coral/content/commons/sidepanels/imagepresetsdetail/imgagepresetslist/datasource的影像預設集資料來源

    chlimage1-495

  5. 在limit屬性中,將數字變更為所要的數字,例如{empty requestPathInfo.selectors[1] ? "20" : requestPathInfo.selectors[1]}。 此運算式設定當要求路徑中未提供明確選取器值時所適用的遞補限制(在此範例中為​20)。

  6. 選取「儲存全部」​​以套用並保留更新的限制。

建立影像預設集 creating-image-presets

影像預設集​是一組已儲存、可重複使用的影像設定,當您預覽或發佈​ 時,可套用至 ​跨影像套用一致的設定。 建立​ 影像預設集 ​可確保透過預設集處理的所有資產共用相同的維度、格式和演算選項,藉此簡化大規模影像傳送並減少手動設定。

NOTE
如果使用Internet Explorer 9 (IE9),新建立的預設集不會在儲存後立即出現在預設集清單中。 若要解決此問題,請停用IE9的快取。

如果您打算支援​ Adobe Illustrator (AI)、PDF和PostScript (EPS) ​檔案的擷取,以便產生這些檔案格式的動態轉譯,請在建立影像預設集之前檢閱下列資訊。

請參閱Adobe Illustrator (AI)、PostScript® (EPS)和PDF檔案格式。

如果您想要支援​ INDD ​檔案的擷取,以便產生此檔案格式的動態轉譯,請在建立影像預設集之前檢閱下列資訊。

請參閱InDesign (INDD)檔案格式。

若要建立影像預設集:

  1. 在Experience Manager中,選取Experience Manager標誌以存取全域導覽主控台,然後前往​工具 > Assets > 影像預設集。

  2. 選取「建立」。

    chlimage1-496

    note
    NOTE
    若要讓此影像預設集具有回應性,請擦除​ 寬度 ​和​ 高度 ​欄位中的值,並保留空白。 空白維度欄位可讓轉譯縮放至請求內容,而非固定至單一大小。
  3. 在​ 編輯影像預設集 ​視窗中,視需要在​ 基本 ​和​ 進階 ​標籤中輸入值,包括名稱。 這些選項在「影像預設 集選項」中概述。 預設集會出現在左窗格中,並可即時套用至其他資產。

    65imagepreset-edit

  4. 選取「儲存」。

建立回應式影像預設集 creating-a-responsive-image-preset

Adobe Experience Manager中的​ 回應式影像預設集 ​是一種影像預設集,可傳送不含固定畫素尺寸的影像,讓演算後的影像自動調整為請求裝置或檢視區的大小。 若要建立預設集,請執行建立影像預設集中的步驟。

定義步驟是​將高度和寬度欄位保留空白。 在​ 編輯影像預設集 ​視窗中,擦除高度和寬度欄位中的任何現有值,讓兩者都為空白。

將​ 高度和寬度欄位保留空白 ​會向Experience Manager指出此影像預設集是​回應式。 因此,預設集不會將資產鎖定為固定尺寸,而是提供縮放以符合目標顯示內容的影像。 您可以視需要調整所有其他的影像預設值。

NOTE
若要在套用影像預設集至資產時檢視​ URL ​和​ RESS ​按鈕,必須發佈資產。
chlimage_1-79
影像預設集和影像資產會自動發佈。

影像預設集選項 image-preset-options

當您建立或編輯「影像預設集」時,會有本節所述的選項。 此外,Adobe建議從下列「最佳實務」選項選擇開始:

  • 格式 (基本​標籤) — 選取​JPEG (聯合攝影專家群組)或其他符合您需求的格式。 所有網頁瀏覽器都支援JPEG影像格式,使其成為最相容的網頁傳送選擇,並在小檔案大小和影像品質之間取得良好的平衡。 不過,JPEG影像使用​有失真壓縮配置,這表示會捨棄部分影像資料以縮減檔案大小。 如果壓縮設定太低,此捨棄程式將會引入不想要的視覺成品,例如封鎖或級區。 因此,Adobe建議將壓縮品質設為​75,這個值可在視覺精確度和小檔案大小之間取得最佳平衡。

  • 啟用簡單銳利化 — 請勿選取​啟用簡單銳利化。 此銳利化濾鏡提供的控制精度低於「不銳利化遮色片」設定,因此將其停用可保留更精細、更可設定的銳利化選項。

  • 銳利化:重新取樣模式 — 選取​銳利化2,Adobe建議使用重新取樣模式以獲得高品質輸出。

基本索引標籤選項 basic-tab-options

欄位
說明
名稱
輸入不含空格的描述性名稱。 為協助使用者識別此影像預設集,請在名稱中包含影像大小規格。
寬度和高度
輸入遞送影像的畫素大小。 寬度和高度必須大於0畫素。 如果任一值為0,則不會建立預設集。 如果兩個值都為空白,則會建立回應式影像預設集,讓影像根據其請求內容調整傳送的大小。
格式
從功能表中選擇格式。
選擇​JPEG (Joint Photographic Experts Group)可提供下列其他選項:
· 品質 - JPEG品質評比範圍介於​ 1到100 ​之間。 拖曳滑桿時會顯示比例。
· 啟用JPG色度縮減取樣 — 人類視覺系統對高頻色彩資訊的敏感性低於對高頻明度的敏感性。 因此,JPEG影像會將影像資訊劃分為明度和色彩元件。 壓縮JPEG影像時,明度分量會保留為完整解析度,而色彩分量會透過將畫素群組平均來縮減取樣。 因為色彩元件是平均的,所以縮減取樣會將資料量減少一半或三分之一,對感知品質的影響極小。 縮減取樣不適用於灰階影像。 此技術會減少高對比影像(例如文字重疊的影像)的可用壓縮量。

選擇​GIF (圖形交換格式)或使用alpha 的 GIF可提供這些額外的​ GIF色彩量化 ​選項:
· 型別 — 選取​最適化 (預設)、網頁​或​Macintosh。 如果您選取​ 具有Alpha ​的GIF,Macintosh選項將無法使用。
· Dither — 選取​ 擴散 ​或​關閉。
· 色彩數目 — 輸入從​ 2到256 ​的數字。
· 色彩清單 — 輸入逗號分隔的清單。 例如,對於白色、灰色和黑色,請輸入000000,888888,ffffff。

選擇​PDF (可攜式檔案格式)、TIFF (標籤影像檔案格式)或​ 含Alpha的TIFF ​可提供此額外選項:
· 壓縮 — 選取壓縮演演算法。 PDF的演演算法選項為​None、Zip​和​Jpeg;TIFF的演演算法選項為​None、LZW (Lempel-Ziv-Welch)、Jpeg​和​Zip;使用Alpha的TIFF的演演算法選項為​None、LZW​和​Zip。

選擇​PNG(可移植網路圖形)、PNG (Alpha為)或​EPS(封裝的PostScript)不提供其他選項。
銳利化
選取​「啟用簡單銳利化」,在所有縮放完成後將基本銳利化濾鏡套用至影像。 銳利化可彌補影像以不同於原始大小顯示時可能產生的模糊。

進階索引標籤選項 advanced-tab-options

進階索引標籤​會將與標準日常設定分開的其他設定控制項分組。 這些選項可讓有經驗的使用者精細控制大部分使用者永遠不需要變更的行為,因此這些選項會放置在專用標籤中,而非主要設定檢視。 將進階控制項保留在其自己的標籤中,可減少一般使用者的雜亂,同時仍會向需要它的使用者顯示強大的設定。

何時使用進階標籤

進階選項適用於預設行為之外的情境。 您通常應在下列情況下使用進階索引標籤:

  • 預設設定不符合特定技術或工作流程需求。
  • 您需要覆寫用於疑難排解或診斷的標準行為。
  • 需要自訂整合、相容性或效能調整。
  • 管理員或超級使用者正在為專用使用案例設定環境。

因為此處進行的變更可能會以標準設定所沒有的方式影響穩定性或行為,所以最佳實務是在修改每個選項之前對其進行檢閱。

常用的進階標籤選項

雖然確切的控制項會因應用程式而異,但「進階」頁簽通常會整合下列設定:

  • 效能與資源控制 — 可調整應用程式使用記憶體、處理或快取方式的選項。
  • 相容性設定 — 可針對舊系統、替代格式或特定環境調整行為的切換。
  • 記錄與診斷 — 啟用詳細記錄或偵錯輸出的控制項,以協助識別問題。
  • 安全性與存取控制 — 管理許可權、加密或驗證行為的設定。
  • 自訂和實驗功能 — 預設未啟用的選擇性功能。
  • 重設及還原控制項 — 將進階設定恢復為預設狀態的選項。

進階選項為何分開

進階設定會與主介面隔離,因為它們具有變更核心行為的較高潛力。 這種分離可確保日常使用者獲得更簡單的體驗,而進階使用者則保留對詳細設定的完整存取權。 因此,進階索引標籤會作為受控空間,可以刻意進行更深入的調整,而不是意外進行。

對於大多數使用者,預設設定就足夠了,並且不需要修改進階索引標籤。 但是,當需要自訂時,這些選項提供了靈活性,可以精確地根據指定的工作流程、環境或需求定製應用程式。

銳利化:定義與概觀

銳利化​是一種影像處理技術,藉由增強​邊緣對比度 (沿相鄰區域邊界亮度或色調的差異)來增加影像的外觀細節與清晰度。 用技術術語來說,銳利化會提高影像的​音階,這是衡量邊緣突遭色調轉換的度量。 因此,邊緣看起來更清晰,而精細的細節對檢視者來說也變得更清晰,即使銳利化不會新增真正的新資訊,而尚未擷取。

銳利化的運作方式

銳利化的運作方式是放大邊緣的區域性對比度,而非均勻地橫跨整個影像。 在較亮和較暗區域之間偵測到邊界時,程式會使過渡的較亮一側變亮,並使該過渡的較暗一側變暗。 由於人類的視覺系統會將高邊緣對比度解讀為銳利度,因此這種選擇性調整會讓影像讀取時更聚焦且更詳細。

大多數銳利化方法的常見核心步驟包括:

  1. Edge偵測 — 識別主要色調轉換發生的位置。
  2. 對比放大 — 增加每個偵測到的邊緣的較亮邊和較暗邊之間的差異。
  3. 控制強度和半徑 — 決定效果有多強,以及效果在每個邊緣周圍延伸多遠。

常見的銳利化方法

  • 不銳利化遮色片(USM):​儘管名稱為不銳利化遮色片(USM)​​技術會銳利化影像。 其運作方式是從原始影像中減去模糊(不銳利化)的影像復本,以隔離邊緣,然後沿著這些邊緣提高對比度。 USM因提供精確控制效果的強度和散佈而廣為使用。
  • 高通篩選:​此方法會隔離影像的高頻元件(對應至細微的細節和邊緣),並強化這些元件,增加感知的銳利度。
  • 以反褶積為基礎的銳利化:​更進階的方法會嘗試反轉特定的模糊形式,復原擷取期間遺失的詳細資訊。

實用程式

銳利化適用於攝影、數位影像、列印和顯示技術。 它在工作流程的兩個階段特別有用:

  • 擷取銳利化​可補償相機感測器和鏡頭帶來的輕微柔化。
  • 輸出銳利化​會為最終媒體準備影像,因為列印和縮減縮放會減少表面細節。

只要謹慎套用,銳利化就能恢復專業影像所預期的清晰感。 但過度套用,會產生可見的成品,例如邊緣的明亮或暗色​ 光暈 ​和放大的雜訊,因此限制和適當的設定是自然結果所必需的。

欄位
說明
色彩空間
選取色域的 RGB、CMYK、 或灰階。
色彩設定檔
如果資產與正在處理的設定檔不同,請選取要轉換為該資產的輸出色域設定檔。
渲染方法

您可以覆寫預設的色彩演算比對方式。 彩現意圖決定了在目標色彩設定檔中無法重現(超出色域)的色彩會發生什麼情況。 如果演算色彩比對方式與ICC設定檔不相容,則會予以忽略。

  • 選取可感知,當原始影像中的一或多個顏色超出目的地色域的色域時,將總色域從一個色域壓縮到另一個色域。
  • 選取相對色度 (當目前色域中的顏色超出目標色域的色域時)。 而且您想要將其對應到最接近的目標色域,而不變更其他顏色。
  • 如果您想要在轉換為目標色域時重現原始影像色彩飽和度,請選取飽和度。
  • 選取 絕對比色 以完全符合顏色,不會調整會改變影像亮度的白點或黑點。
黑點補償
如果輸出設定檔支援此功能,請選取此選項。 如果黑點補償與指定的ICC設定檔不相容,則會忽略黑點補償。
正在遞色
選取此選項可避免或減少可能的色階誤差。
銳利化型別

選取無、銳利化或不銳利化遮色片。

  • 若要停用銳利化,請選取無。
  • 選取「銳利化」可在所有縮放完成後套用基本銳利化濾鏡至影像。 銳利化有助於彌補以不同大小顯示影像時可能產生的模糊。
  • 如果要微調最終縮減取樣影像的銳利化濾鏡效果,請選取不銳利化遮色片。 您可以控制效果的強度、效果的半徑(以畫素測量)以及被忽略的對比度臨界值。 此效果使用與Photoshop的「遮色片銳利化」濾鏡相同的選項。

在 不銳利化遮色片 中,您有以下選項:

  • Amount — 控制套用至邊緣畫素的對比量。 預設實數值為1.0。 若是高解析度的影像,最高可增加到5.0。 將「數量」視為濾鏡強度的量度。
  • 半徑 — 決定邊緣畫素周圍影響銳利化的畫素數量。 對於高解析度的影像,請輸入從1到2的實數。 低值只會銳利化邊緣畫素;高值會銳利化較寬的畫素範圍。 正確的值取決於影像的大小。
  • 臨界值 — 決定套用「遮色片銳利化」濾鏡時要忽略的對比範圍。 換言之,此選項會定義銳利化的畫素與周圍區域的差異程度,才會被視為邊緣畫素並予以銳利化。 為避免引入雜訊,請嘗試使用2到20的整數值。
  • 套用至 — 決定取消銳利化是套用至每個色彩還是亮度。

銳利化的說明請參閱 搭配Experience Manager Dynamic Media使用影像銳利化影片、銳利化影像線上說明主題,以及在Dynamic Media Classic中銳利化影像的最佳作法可下載的PDF。

重新取樣模式

選取 重新取樣模式 選項。 這些選項會在縮減取樣影像時銳利化影像:

  • 雙線性式 — 最快速的重新取樣方法。 會產生某些明顯的鋸齒狀不自然感。
  • 雙立方式 — 增加CPU使用量,但會產生較清晰的影像,且鋸齒狀不自然感比較不明顯。
  • 銳利化2 — 產生的結果可能會比「雙立方式」稍微銳利,但耗用的CPU成本更高。
  • Bi-Sharp — 選取Photoshop預設的重新取樣器以縮減影像大小,在Adobe Photoshop中稱為雙立方銳利化。
  • 每個色彩和亮度 — 每個方法都可以根據色彩或亮度。 依預設,會選取每個色彩。
列印解析度
選取列印此影像的解析度;預設為72畫素。
影像修飾元

除了UI中可用的通用影像設定之外,Dynamic Media還支援您可以在 影像修飾元 欄位中指定的多項進階影像修改。 這些引數定義於影像伺服器通訊協定命令參考。

重要:不支援API中列出的以下功能:

  • 基本範本化和文字演算命令: text= textAngle= textAttr= textFlowPath= textFlowXPath= textPath=和 textPs=
  • 本地化命令: locale=和 req=xlate
  • req=set 無法用於一般用途。
  • req=mbrset
  • req=saveToFile
  • req=targets
  • template=
  • 非核心Dynamic Media服務:SVG、影像演算和Web對列印

使用影像修飾元定義影像預設集選項 defining-image-preset-options-with-image-modifiers

影像修飾元可擴充「基本」和「進階」標籤中的可用選項,讓您在定義影像預設集時擁有更多控制權。 影像演算依賴Dynamic Media影像演算API,並在HTTP通訊協定參考中詳細定義。 每個修飾元都是影像伺服命令(以運運算元命令的​ op_首碼 ​識別),可轉換演算後的影像顯示方式。

以下是一些您可以使用影像修飾元進行操作的基本範例。

NOTE
部分影像修飾元無法在Experience Manager中使用。
  • op_invert — 反轉每個顏色元件以產生負影像效果。 將值設定為​ 1 ​會啟用反轉,產生攝影負片。

    code language-xml
    
    &op_invert=1
    

    65imagepreset-edit-invert

  • op_blur — 將模糊濾鏡套用至影像。 較高的值會產生較強柔化效果;以下範例會套用​ 7 ​的模糊強度。

    code language-xml
    
    &op_blur=7
    

    65imagepreset-edit-blur

  • 合併的命令 — 您可以在單一要求中鏈結多個影像修飾元,讓兩個效果一起套用。 下列專案結合了​ op_invert ​和​op_blur,將顏色反轉,並在一個演算輸出中套用7的模糊。

    code language-xml
    
    &op_invert=1&op_blur=7
    

    chlimage1-80

  • op_brightness — 減少或增加影像的亮度。 提供的值會調整明度,因此提高亮度會使影像變亮,降低亮度會使其變暗。 此範例套用亮度值​58。

    code language-xml
    
    &op_brightness=58
    

    65imagepreset-edit-brightness

  • opac — 調整影像不透明度,讓您減少前景不透明度,讓影像變得更加透明。 此範例設定不透明度值為​29。

    code language-xml
    
    opac=29
    

    65imagepreset-edit-opacity

編輯影像預設集 modifying-image-presets

Experience Manager中的影像預設集可重複使用、儲存的設定,可定義如何動態調整影像大小、格式化和針對傳送最佳化。 編輯現有影像預設集可讓您更新這些設定,以便從該預設集產生的每個影像轉譯都反映新的設定。

若要編輯現有的影像預設集,請執行下列步驟:

  1. 在Experience Manager中,選取Experience Manager標誌以存取全域導覽主控台,然後前往​工具 > Assets > 影像預設集。

    65imagepreset-editpreset

  2. 選取預設集,然後選取​編輯。 編輯影像預設集​視窗隨即開啟。

  3. 對預設集設定進行變更,然後選取[儲存]以套用並儲存更新的設定,或選取[取消]以捨棄變更。 ​​ ​ ​選取「儲存」可確保從預設集產生的每個影像轉譯都會立即採用更新的設定。

發佈影像預設集 publishing-image-presets

影像預設集​已​自動發佈。 影像預設集​是可重複使用的組態,可定義影像的處理及傳送方式,包括大小、裁切、格式及品質等設定,以便相同處理方式能一致地套用至許多資產。

由於發佈會自動進行,因此不需要個別的手動發佈步驟。 因此,您建立或更新的每個影像預設集都可供使用,無需您執行其他動作。 這可確保您的預設集保持同步並立即可用,減少取消發佈或過時設定的風險。

自動發佈的運作方式

  • 建立或修改影像預設集時,系統​會自動為您發佈。
  • 然後,發佈的預設集就可供依照其定義的設定傳送影像。
  • 無需手動發佈工作流程即可啟用預設集。

自動發佈的優點

  • 沒有手動步驟:​預設集不需要個別發佈,精簡工作流程。
  • 一致性:​自動發佈可讓預設集保持最新狀態,並在影像間統一套用。
  • 可靠性:​這能減少使用過時或未發佈的預設集的機會,確保影像依設定傳送。

刪除影像預設集 deleting-image-presets

刪除影像預設集會將其從Dynamic Media中永久移除,因此當對資產套用預設集型演算時,將無法再使用它。 因為刪除是永久性的,Dynamic Media需要確認才能完成動作。

  1. 在Experience Manager中,選取Experience Manager標誌以存取全域導覽主控台,然後選取​ 工具 ​圖示。
  2. 導覽至​Assets > 影像預設集。
  3. 選取您要移除的預設集,然後選取​刪除。 Dynamic Media會顯示確認提示,以確認您要刪除選取的預設集。 此確認步驟旨在防止意外移除。 選取​ 刪除 ​以永久移除預設集,或選取​ 取消 ​以返回​ 影像預設集 ​而不進行變更。
recommendation-more-help
experience-manager-cloud-service-help-main-toc