延遲付款服務報表資料

本文說明Adobe Commerce中付款服務報表資料延遲的原因,以及如何解決問題。

說明 description

環境

Adobe Commerce v2.4.0 -2.4.4

問題

付款服務報表資料(用於付款和訂單付款狀態報表)可能不會立即同步。

例如,在您針對訂單開立商業發票(擷取)或發出銷退折讓單之後,訂單的狀態可能無法立即使用。

要再現的步驟:

先決條件:使用「付款服務」功能下訂單。

  1. 在「管理員」中為訂單開立商業發票(或透過銷退折讓單取消或退款)。
  2. 切換作業選項至「訂單付款狀態」報表,以檢視有關該訂單的資訊。
  3. 狀態會顯示為「已授權」,這是開立商業發票或其他訂單作業之前的訂單狀態。

Commerce尚未同步資料並將其傳送至Payment Services,因此報表尚未識別新訂單狀態。

注意 這只是一個常見的使用案例。 訂單動作發生時,可能還有其他使用案例,且資料無法立即在適用的報表中使用。

預期結果:
當訂單上有動作時,報表資料會立即填入。

實際結果:
剛完成的訂單動作的報表資料可能會有所延遲。 付款報告可能會發生24到48小時的延遲。 訂單付款狀態報告可能會延遲數小時。

原因
有兩個因素會影響「管理員」中可見資料的延遲:

  • 您透過「管理員」中的設定,選擇從Commerce同步(匯出和保留)資料的頻率。
  • PayPal發佈報表資料的時間範圍。

解決方法 resolution

針對「訂單」付款狀態報表:

  1. 瀏覽至 銷售 > 付款服務
  2. 按一下 訂單付款狀態 以檢視訂單付款狀態報表表格。
  3. 按一下報表表格右上角的 強制重新同步 圖示,以強制重新同步。 您應該會看到上次更新的時間戳記變更,以及報表表格中載入的新交易。

在PayPal支付報表中,由於相依於PayPal的資料發佈時間範圍,預期結果會延遲24至48小時。

recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f