PayPal閘道已拒絕請求 — 重複發票問題

本文針對PayPal閘道遭拒絕的請求提供修正 — 重複發票問題。

提交付款時,客戶可能會看到重複商業發票的錯誤:

PayPal閘道已拒絕要求。 已為此InvoiceID付款(#10412:重複發票)

將具有相同ID的商業發票多次傳送到PayPal時,會發生此問題。

若要解決此問題,請在PayPal的「付款接收偏好設定」中,允許每個商業發票識別碼進行多項付款。 變更後,PayPal會接受不含錯誤訊息的付款,即使是具有重複ID的商業發票亦然。

受影響的版本

  • Adobe Commerce內部部署,所有版本
  • 雲端基礎結構上的Adobe Commerce,所有版本

問題

提交付款時,客戶會看到錯誤訊息:

... main.CRITICAL: Exception message: PayPal gateway has rejected request. Payment has already been made for this InvoiceID (#10412: Duplicate invoice).

PayPal無法處理付款並完成訂單。

原因

將具有相同ID的商業發票多次提交至PayPal時,便會顯示錯誤訊息。

跨多個Adobe Commerce網站(甚至跨本機和中繼環境)使用相同的認證時,可能會發生這種情況。 特定情況可能如下:

  • 多個商店將商業發票提交至PayPal,並使用相同的商業發票ID
  • 新存放區會傳送發票,其識別碼先前已由舊存放區提交

依預設,PayPal不允許處理相同發票兩次。

解決方案

變更您的PayPal設定檔,以允許每個發票ID進行多項付款。 您必須透過PayPal進行這些變更。

  1. https://www.paypal.com登入您的帳戶。
  2. 按一下​ 設定檔 > 設定檔與設定 (右上角)。
  3. 移至​ 我的銷售工具
  4. 瀏覽至​ 取得付款並管理我的風險 > 封鎖付款,然後按一下​ 更新
  5. 銷售偏好設定,按一下​ 付款接收偏好設定
  6. 在​ 封鎖意外付款 ​底下,選擇​ 否,允許每個發票識別碼有多個付款 paypal_allow_multiple_payments_per_invoice_id.png
  7. 捲動至底部,然後按一下​ 儲存

更多資訊

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a