Adobe Commerce 2.4.1問題:無法在Chrome中變更Amazon帳戶

本文會說明一個已知的Adobe Commerce 2.4.1問題,客戶在結帳期間使用Amazon Pay時,需登入先前使用的Amazon帳戶,而非建議登入。

受影響的產品和版本

  • Adobe Commerce內部部署2.4.1
  • 雲端基礎結構上的Adobe Commerce 2.4.1

問題

客戶在結帳期間使用Amazon Pay時,會登入先前使用的Amazon帳戶,而不是被建議登入。

要再現的步驟:

  1. 在店面,將任何專案新增到購物車並繼續來賓結帳。
  2. 按一下​ Amazon Pay ​按鈕。 Amazon.com登入快顯視窗會出現。
  3. 登入Amazon帳戶。
  4. 選取地址,然後按一下​ 下一步
  5. 選取付款方式。
  6. 按一下​ 下訂單
  7. 返回首頁並登入商店帳戶。
  8. 再次新增任何專案至購物車並繼續結帳。
  9. 按一下​ Amazon Pay ​按鈕。

實際結果:

您會再次自動登入先前使用的(步驟3) Amazon帳戶。

預期結果:

Amazon.com登入快顯視窗會出現,您可以登入或為Amazon Pay建立新帳戶。

原因

此問題可能會發生在以下情況之一:

  • SameSite Cookie值為LAX時,Cookie將不會作為任何第三方呼叫的一部分傳送。
  • Mozilla Firefox內容封鎖功能可防止第三方透過封鎖指令碼和使用者端儲存機制的使用來追蹤瀏覽器使用者的活動。 Firefox使用外部廠商Disconnect.me提供要封鎖的追蹤網站清單。 Amazon Pay會在第三方網站上使用iframe,在登入後傳回存取權杖,並轉譯位址和公事包Widget。 透過內容封鎖功能,Amazon Pay iframe載入請求會被視為協力廠商追蹤請求並被封鎖,導致購買者無法繼續結帳。
  • 瀏覽器明確封鎖第三方Cookie或JS的任何情況。

解決方案

請確定Amazon Pay iframe請求未遭到瀏覽器的封鎖。

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