啟用Braintree付款時,管理員無法建立訂單/重新訂單
本文提供Adobe Commerce 2.4.5問題的修補程式,此問題發生在啟用Braintree付款方法時,管理員使用者無法建立客戶的訂單或重新訂單。
說明 description
環境
- 雲端基礎結構上的Adobe Commerce 2.4.5
- Adobe Commerce內部部署2.4.5
- Magento Open Source 2.4.5
問題/症狀
要再現的步驟:
- 已使用核心Braintree整合(商店)
>
組態>
銷售>
付款方式>
Braintree)。 - 使用Luma店面下訂單。
- 移至Admin UI
>
銷售。 - 嘗試為客戶建立新訂單,或前往先前下單的訂單,然後按一下 重新訂購。
預期結果:
啟用Braintree付款方式時,管理員使用者就能成功建立客戶的訂單和重新訂單。
實際結果:
啟用Braintree付款方式時,管理員使用者無法為客戶建立訂單或重新訂單,並傳回下列錯誤:
report.CRITICAL: Error: Call to a member function getMethodInstance() on null in /app/vendor/paypal/module-braintree-core/Block/Form.php:174
原因
不正確的類別相依性(vendor/paypal/module-braintree-core/Block/Form.php
)
解決方法 resolution
解決方案
套用本文提供的修補程式。
修補
此修補程式已附加至本文。 若要下載,請按一下以下連結:
BUNDLE-3137-composer-patch.zip
附註:
此外,適用於Adobe Commerce on cloud infrastructure商家: Adobe已在Commerce 1.0.18版的雲端修補程式中納入修正。如需指示,請參閱我們的支援知識庫中的如何套用Adobe提供的撰寫器修補程式。
recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f