New Relic云基础架构上的Adobe Commerce疑难解答

本文提供用于对Adobe Commerce上的New Relic进行云基础架构故障诊断的资源。

问题
原因
资源
访问问题

在New Relic中看不到项目。

您登录到 New Relic,但看不到您应有权查看/访问的项目。

在这些情况下,管理员用户需要将您添加到项目中。
访问我们的支持知识库中的New Relic服务
数据问题

安装后缺少数据。

使用New Relic诊断实用程序尝试找出原因。 如果这样没有帮助,请查看特定于代理的解决方案。 右侧列中提供了指向包含这些解决方案的文章的链接。

缺失数据可能由不同原因引起。 您可能需要:

  • 验证是否已安装代理。
  • 验证您的应用程序名称和许可证密钥。
  • 重新启动Web服务器。
  • 确保您的系统符合兼容性要求。
  • ini设置。
交易时间戳不一致。 您可能很难使用New Relic UI找到时间较长的交易(超过5分钟)。 您还可能会发现所显示的事务超出了预期的时间范围。
New Relic UI显示交易结束的时间,而不是交易开始的时间。
要使用New Relic UI计算交易的开始,请检查交易的持续时间。 从New Relic UI提供的时间戳(交易结束)中减去持续时间量。
使用|%等特殊字符的 NerdGraph GraphQL curl查询不起作用
NerdGraph中的New Relic“复制到curl”功能当前不提供处理特殊字符(如|%)的方法。
使用不同的API库解决具有特殊字符的问题。 例如,用于Python上Graphql API的GraphQLClient库,或通过Java语言调用的Apache.commons。 查看GraphQL上的客户端库。
图表和功能板显示问题。
通过将New Relic域添加到允许列表或卸载导致问题的浏览器扩展来解决缺少的图表。
New Relic文档>图表缺失或不呈现
PHP代理问题
PHP代理未显示正确的实例计数。
实例的数量会根据后端进程和吞吐量而增加。 服务器值之间的差异可能是由一台服务器上运行的进程导致的,而不是另一台服务器上运行的进程导致的。
New Relic文档> PHP代理实例计数疑难解答
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a