Adobe Commerce 2.4.1问题:无法在Chrome中更改Amazon帐户

本文介绍了一个已知的Adobe Commerce 2.4.1问题,其中客户在结账期间使用Amazon Pay登录之前使用的Amazon帐户,而不是建议登录。

受影响的产品和版本

  • Adobe Commerce内部部署2.4.1
  • 云基础架构上的Adobe Commerce 2.4.1

问题

在结账期间使用Amazon Pay时,客户会登录到以前使用的Amazon帐户,而不是被建议登录。

要再现的步骤:

  1. 在店面,将任何物品添加到购物车并继续执行访客结账。
  2. 单击​ Amazon Pay ​按钮。 Amazon.com登录弹出窗口。
  3. 登录到Amazon帐户。
  4. 选择地址并单击​ 下一步
  5. 选择付款方式。
  6. 单击​ 下订单
  7. 返回主页并登录到商店帐户。
  8. 再次将任何项目添加到购物车并继续结帐。
  9. 单击​ Amazon Pay ​按钮。

实际结果:

您将再次自动登录到以前使用的(步骤3) Amazon帐户。

预期结果:

Amazon.com登录弹出窗口,您可以登录或为Amazon Pay创建新帐户。

原因

在以下情况之一中,可能会发生问题:

  • SameSite Cookie值为LAX时,该Cookie将不会作为任何第三方调用的一部分发送。
  • Mozilla Firefox内容阻止功能可阻止使用脚本和客户端存储机制,从而阻止第三方跟踪浏览器用户的活动。 Firefox使用外部供应商Disconnect.me提供要阻止的跟踪站点的列表。 Amazon Pay使用第三方网站上的iframe在登录后返回访问令牌,并渲染地址和钱包小组件。 借助内容阻止功能,Amazon Pay iframe加载请求被视为第三方跟踪请求并被阻止,导致购买者无法继续结账。
  • 浏览器明确阻止第三方Cookie或JS的任何情况。

解决方案

确保浏览器不会阻止Amazon Pay iframe请求。

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