Nya kunder visas inte i kundrutnätet efter CSV-import

Den här artikeln innehåller en korrigering av problemet när du inte kan se nya kunder under Kunder > Alla kunder efter en import från en .csv-fil. Lösningen är att ställa in indexeraren customer_grid på läget"Uppdatera vid spara" och manuellt indexera om kundstödrastret.

Berörda versioner

  • Adobe Commerce lokal 2.2.0 och senare
  • Adobe Commerce om molninfrastruktur 2.2.0 och senare

Problem

När du har importerat nya kunder från en .csv-fil med den inbyggda Adobe Commerce-importfunktionen kanske du inte kan se de nya kundposterna under Kunder > Alla kunder i Admin förrän du indexerar om customer_grid-indexeraren manuellt.

Orsak

Indexeringsläget Uppdatera vid schema i Adobe Commerce 2.2.0 och senare stöder inte indexeraren customer_grid på grund av prestandaproblem.

Lösning

Konfigurera customer_grid-indexeraren så att den indexeras om med läget Uppdatera vid spara. Gör så här:

  1. Logga in på Commerce Admin.
  2. Klicka på System > Verktyg > Indexhantering.
  3. Markera kryssrutan bredvid indexeraren för kundstödraster.
  4. Välj Uppdatera vid Spara i listrutan Åtgärder.
  5. Klicka på Skicka.

Vi rekommenderar även att du indexerar om indexeraren customer_grid manuellt efter att du har konfigurerat indexeringsläget för att se till att indexet är uppdaterat och kan fungera med cron. Använd följande kommando om du vill indexera om manuellt:

bin/magento indexer:reindex customer_grid

Mer information

Länkar till relaterade ämnen i vår utvecklardokumentation:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a