Adobe Commerce statuskolumn saknar exporterad produkt, CSV-fil
Den här artikeln innehåller en lösning på problemet när du inte kan hitta statuskolumnen (d.v.s. ange om produkten är aktiverad eller inaktiverad) i CSV-filen som innehåller exporterade produkter. Produktens status anges av kolumnen product_online.
Berörda produkter och versioner
Adobe Commerce (alla distributionsmetoder) alla versioner som stöds
Problem
Du kan inte hitta kolumnen status i CSV-filen som innehåller exporterade produkter. Du kan till exempel exportera en CSV-fil med alla SKU:er, med status, men tabellen verkar sakna kolumnen status.
Steg att återskapa:
- I Adobe Commerce Admin väljer du System under Data Transfer select Export.
- I avsnittet Export Settings väljer du i listrutan Entity Type Products.
- Sök efter status, visas under Attribute Code. Attributkoden visas i listan med tillgängliga attribut (Enable Product).
- Klicka på Export.
Förväntat resultat:
I CSV-filen som du just exporterade visas en kolumn med namnet status.
Faktiskt resultat:
Du ser ingen kolumn med namnet status i den exporterade CSV-filen.
Orsak
Produktens statusattribut har bytt namn i CSV-filen. Det är nu kolumnen product_online.
Lösning
- Välj System, under Data Transfer select Import.
- Klicka på Download Sample File.
- Du kan se kolumnen product_online i CSV-filen.
Relaterad läsning
- Arbeta med CSV-filer i vår användarhandbok.
- Referens för produktexportattribut i användarhandboken.