504 gatewaytimeout-fel när en kategori sparas med 1k±produkter
I den här artikeln föreslås en lösning på det timeout-problem du kan ha när du utför åtgärder med stora kategorier (1k±produkter).
Berörda produkter och versioner:
- Adobe Commerce i molninfrastruktur 2.3.3
- Adobe Commerce lokal 2.3.3
- Magento Open Source 2.3.3
Problem
Förutsättningar: Alternativet Lagrar > Konfiguration > KATALOG > Katalog > Använd kategorisökväg för produkt-URL:er är Ja för din butiksvy.
Steg som ska återskapas
- Gå till Katalog > Kategorier i Commerce Admin.
- Öppna en stor kategori, till exempel mer än 1 000 tilldelade produkter.
- Lägg till en produkt i kategorin.
- Klicka på Spara kategori.
Förväntat resultat:
Kategorin har sparats.
Faktiskt resultat:
Efter fem minuters sparande visas sidan med timeout-fel för 504-gateway.
Orsak
Processen tar längre tid än serverns konfigurerade timeout.
Lösning
Om du inaktiverar alternativet Skapa omskrivningar av kategori/produkt tas alla återskrivningar av kategori-/produkt-URL bort från databasen, vilket minskar tiden som krävs för åtgärder med stora kategorier avsevärt.
Så här inaktiverar du alternativet Skapa URL-omskrivningar för kategori/produkt:
- Gå till Lagrar > Konfiguration > KATALOG > Katalog i Commerce Admin.
- I konfigurationsidans övre vänstra hörn anger du konfigurationsomfånget till Standardkonfiguration i fältet Scope.
- Ange Generera URL-omskrivningar för kategori/produkt till Nej.
- Klicka på Spara konfiguration.
- Rensa cachen genom att köra
bash bin/magento cache:clean
eller i Commerce Admin under System > Verktyg > Cachehantering .
Nu kan du lägga till produkter i kategorier eller flytta kategorier med ett stort antal produkter, och dessa åtgärder tar mycket mindre tid och bör inte orsaka timeout.