Erro ao atualizar o AEM 6.4.2+ para AEM 6.5

Quando você receber um erro ao atualizar a versão AEM 6.4.2 para AEM 6.5, pare a instância e siga as instruções fornecidas neste artigo.

Descrição description

Ambiente

  • Experience Manager 6.4
  • Experience Manager 6.5

Problema/Sintomas

Ao atualizar o Adobe Experience Manager (AEM) da versão 6.4.2 (em diante) para a 6.5 e essa instância já foi atualizada do AEM AEM 6.1 ou do 6.2, a atualização pode falhar com um erro de requisito ausente

4.12.2019 15:14:33.439 *ERRO* [ FelixStartLevel] ERRO: Erro do pacote '827' ao iniciar/parar o pacote. (org.osgi.framework.BundleException: Não é possível resolver org.apache.sling.scripting.javascript [ 827] (R 827.0): requisito ausente [ org.apache.sling.scripting.javascript [ 827] (R 827.0)] osgi.walling.package; (&(osgi.walling.package=javax.jcr)(versão> =2.0.0)) Requisitos não resolvidos: [ [ org.apache.sling.scripting.javascript [ 827] (R 827.0)] osgi.walling.package; (&(osgi.walling.package=javax.jcr)(versão> =2.0.0))] )
org.osgi.framework.BundleException: Não é possível resolver org.apache.sling.scripting.javascript [ 827] (R 827.0): requisito ausente [ org.apache.sling.scripting.javascript [ 827] (R 827.0)] osgi.walling.package; (&(osgi.walling.package=javax.jcr)(versão> =2.0.0)) Requisitos não resolvidos: [ [ org.apache.sling.scripting.javascript [ 827] (R 827.0)] osgi.walling.package; (&(osgi.walling.package=javax.jcr)(versão> =2.0.0))]
em org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
em org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
em org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1727)
em org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:338)
em java.lang.Thread.run(Origem desconhecida)
4.12.2019 15:14:33.440 *ERRO* [ FelixStartLevel] ERRO: Erro do pacote '828' ao iniciar/parar o pacote. (org.osgi.framework.BundleException: Não é possível resolver org.apache.sling.scripting.jst [ 828] (R 828.0): requisito ausente [ org.apache.sling.scripting.jst [ 828] (R 828.0)] osgi.walling.package; (&(osgi.walling.package=javax.jcr)(versão> =1.0.0)(!(versão> =3.0.0)) Requisitos não resolvidos: [ [ org.apache.sling.scripting.jst [ 828] (R 828.0)] osgi.walling.package; (&(osgi.walling.package=javax.jcr)(versão> =1.0.0)(!(versão> =3.0.0)))] )
org.osgi.framework.BundleException: Não é possível resolver org.apache.sling.scripting.jst [ 828] (R 828.0): requisito ausente [ org.apache.sling.scripting.jst [ 828] (R 828.0)] osgi.walling.package; (&(osgi.walling.package=javax.jcr)(versão> =1.0.0)(!(versão> =3.0.0)) Requisitos não resolvidos: [ [ org.apache.sling.scripting.jst [ 828] (R 828.0)] osgi.walling.package; (&(osgi.walling.package=javax.jcr)(versão> =1.0.0)(!(versão> =3.0.0)))]
em org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
em org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
em org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1727)
em org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:338)
em java.lang.Thread.run(Origem desconhecida)

Ou este erro:

11.12.2019 10:26:32.102 *ERRO* [ FelixDispatchQueue] com.adobe.granite.crypto FrameworkEvent ERROR (org.osgi.framework.BundleException: Não é possível resolver com.adobe.granite.crypto [ 158] (R 158.3): requisito em falta [ com.adobe.granite.crypto [ 158] (R 158.3)] osgi.walling.package; (&(osgi.walling.package=org.apache.commons.io)(versão> =2.0.1)(!(versão> =3.0.0)) Requisitos não resolvidos: [ [ com.adobe.granite.crypto [ 158] (R 158.3)] osgi.walling.package; (&(osgi.walling.package=org.apache.commons.io)(versão> =2.0.1)(!(versão> =3.0.0)))] ) org.osgi.framework.BundleException: Não é possível resolver com.adobe.granite.crypto [ 158] (R 158.3): requisito em falta [ com.adobe.granite.crypto [ 158] (R 158.3)] osgi.walling.package; (&(osgi.walling.package=org.apache.commons.io)(versão> =2.0.1)(!(versão> =3.0.0)) Requisitos não resolvidos: [ [ com.adobe.granite.crypto [ 158] (R 158.3)] osgi.walling.package; (&(osgi.walling.package=org.apache.commons.io)(versão> =2.0.1)(!(versão> =3.0.0)))]
em org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368) em org.apache.felix.framework.Felix.startBundle(Felix.java:2281) em org.apache.felix.framework.Felix$RefreshHelper.restart(Felix.java:5349) em org.apache.felix.framework.Felix.refreshPackages(Felix.java:4516) em org.apache.felix x.framework.FrameworkWiringImpl.run(FrameworkWiringImpl.java:188) em java.lang.Thread.run(Thread.java:748)

Resolução resolution

Siga as etapas fornecidas abaixo para evitar erros:

  1. Depois de atualizar para 6.5 (ou antes de executar o comando de atualização final), pare a instância

  2. Baixar este commons-io jar ao servidor e coloque-o em crx-quickstart/install.

  3. Reinicie a instância usando o comando abaixo:

    java -server -Xmx1024m -XX:MaxPermSize=256M -Djava.awt.headless=true -Dsling.run.modes=author,crx3,crx3tar -jar cq-quickstart-6.5.0.jar  -p 4502 -Dsling.properties=conf/sling.properties -Dorg.apache.sling.launchpad.startupmode=UPDATE &

  4. Verifique /system/console/bundles. Depois que todos os pacotes estiverem no estado ativo e o sistema for totalmente atualizado, pare a instância novamente.

  5. Reinicie a instância com o comando abaixo:

    java -server -Xmx1024m -XX:MaxPermSize=256M -Djava.awt.headless=true -Dsling.run.modes=author,crx3,crx3tar -jar cq-quickstart-6.5.0.jar -p 4502 -Dsling.properties=conf/sling.properties &

  6. A atualização deve ser concluída com êxito.

Informações adicionais

Esse problema ocorre ao atualizar uma instância do AEM 6.4.2+ que foi atualizada anteriormente do AEM 6.1 ou do AEM 6.2

recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f