AEM: a versão do pacote OOTB é inferior à esperada

Descrição description

Problema

No console OSGi Pacotes OSGi, há um pacote cuja versão é inferior à esperada para o SP/CFP instalado. Esta edição não seria uma edição individual. Normalmente, algo crítico acontece (por exemplo, falha de logon no AEM) e a investigação revela isso como uma causa intermediária.

Causa

Possivelmente, a atualização do pacote falhou na instalação do SP/CFP. Uma das possíveis causas da falha de atualização é o fato de alguém ter iniciado o AEM como usuário root antes e depois como usuário regular. Durante a execução como usuário raiz, crx-quickstart/launchpad/felix/bundleXX era de propriedade da raiz. No momento da instalação do SP/CFP, o AEM, que está sendo executado como o usuário regular, não pode gravar em bundleXX e a atualização do pacote falhou.

Resolução resolution

Verifique o proprietário do arquivo/diretório em crx-quickstart. Se algum arquivo/diretório não pertencer ao usuário regular para o processo AEM, execute as seguintes etapas.

(1) Parem o AEM.

(2) Volte o proprietário para o usuário normal.

(3) Iniciar o AEM.

(4) Reinstale o SP/CFP.

recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f