Atualize para o esquema DHL versão 10.0 para continuar oferecendo o envio para a DHL

Este artigo fornece uma solução para permitir que os comerciantes continuem oferecendo o transporte para a DHL depois que a versão 6.2 do esquema da DHL for descontinuada no final de dezembro de 2022.

Produtos e versões afetados

  • Adobe Commerce 2.4.5 e versões anteriores, todos os métodos de implantação.

Problema

Em agosto de 2022, lançamos o atualização do esquema DHL versão 6.2. juntamente com uma correção para que os comerciantes continuassem a oferecer serviços de transporte à DHL. A DHL está introduzindo novamente um esquema mais recente, a versão 10.0, em outubro de 2022, e a versão anterior (esquema 6.2) será descontinuada no final de dezembro de 2022. O Adobe Commerce 2.4.5 e a integração anterior da DHL são compatíveis apenas com a versão 6.2.

Solução

O Adobe Commerce 2.4.5-p1 e 2.4.4-p2, lançados em outubro de 2022, contêm o novo esquema DHL versão 10.0. Portanto, os comerciantes que atualizam para 2.4.5-p1 e 2.4.4-p2 não precisam fazer nada para continuar oferecendo os carregamentos da DHL. Recomendamos que todos os comerciantes atualizem para 2.4.5-p1 e 2.4.4-p2 antes da desativação do esquema DHL 6.2 no final de dezembro de 2022.

Os comerciantes que não desejam atualizar para 2.4.5-p1 e 2.4.4-p2 precisarão aplicar um patch fixo se quiserem continuar oferecendo o envio para a DHL após dezembro de 2022.

Correção

O ID do patch é AC-3023 e está disponível no Quality Patches Tool versão 1.1.21.

Consulte os links a seguir para saber como usar o Quality Patches Tool e instale patches dependendo de seus métodos de implantação:

O patch é aplicável às seguintes versões do Adobe Commerce (todos os métodos de implantação):

  • 2.3.7, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.3-p2, 2.4.3-p3, 2.4.4

Leitura relacionada

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a