Falha no serviço Redis
O artigo recomenda como consertar o Redis.
Produtos e versões afetados
- Adobe Commerce na infraestrutura em nuvem 2.2.x., 2.3.x
- Adobe Commerce no local 2.2.x., 2.3x
- Todas as versões do Redis
Problema
Lentidão ou paralisação do site devido a estouro de memória no Redis.
Causa
O estouro de memória pode causar falha no serviço Redis. Durante o horário de pico, o serviço Redis pode exigir mais memória do que a alocada no momento.
Solução
Para verificar a configuração atual e a memória usada, execute o seguinte comando na CLI. Ele verifica a memória usada, maxmemory, chaves removidas e o tempo de atividade do Redis em dias:
redis-cli -p REDIS_PORT -h REDIS_HOST info | egrep --color "(role|used_memory_peak|maxmemory|evicted_keys|uptime_in_days)"
As variáveis REDIS_PORT e REDIS_HOST podem ser recuperadas de app/etc/env.php
.
Se a saída da execução da consulta acima mostrar que a porcentagem de memória livre é inferior a 40%, envie um tíquete ao suporte da Adobe Commerce solicitando um aumento da configuração maxmemory
no Servidor Redis. Se o valor das chaves removidas não for "0" ou o tempo de atividade do Redis em dias for igual a 0 (indicando que o Redis falhou hoje), você também deve enviar um tíquete ao suporte da Adobe Commerce solicitando uma investigação e uma correção para esse problema.
Leitura relacionada
Para saber mais sobre a memória Redis, consulte Otimização de Memória Redis.