Redirecionamento de logon ao tentar fazer logon no Commerce Admin
Este artigo fornece as soluções possíveis para o problema de logon do Commerce Admin, em que você é redirecionado de volta para o formulário de logon ao tentar fazer logon no Admin e nenhuma mensagem de erro é exibida. Isso inclui a correção das configurações de fuso horário do servidor e a limpeza das configurações de cookies no Adobe Commerce.
Edições e versões afetadas:
Todas as versões e edições do Adobe Commerce.
Problema
Etapas a serem reproduzidas:
- Vá para a página de Administrador do Commerce.
- Insira suas credenciais e clique em Fazer logon.
Resultados esperados:
Você faz logon no Commerce Admin.
Resultados reais:
Você será redirecionado de volta ao formulário de logon sem mensagens de erro.
Causa
Há algumas razões possíveis para o problema:
- Fuso horário incorreto definido no nível do navegador (o que faz com que a sessão do administrador seja considerada expirada, mesmo que o tempo de vida real ainda não tenha expirado).
- Configurações de cookies incorretas, o que faz com que a sessão estabelecida não seja usada pelo Adobe Commerce.
Consulte os próximos parágrafos para obter soluções para cada caso.
Soluções
Problema relacionado ao tempo de vida da sessão do administrador
Tente usar um navegador diferente e aumente o tempo de vida da sessão do administrador se for inferior a uma hora.
Para aumentar o tempo de vida da sessão de administrador, siga estas etapas:
-
Criar um backup de banco de dados.
-
Use uma ferramenta de banco de dados como phpMyAdmin ou acesse o BD manualmente a partir da linha de comando para executar a seguinte consulta SQL:
code language-sql UPDATE core_config_data SET value = 7200 WHERE path = 'admin/security/session_lifetime';
-
Limpe o cache de configuração executando o seguinte comando:
code language-bash php <your_magento_install_dir>/bin/magento cache:clean config
Configurações de cookies incorretas
Para verificar os valores das configurações de cookies e limpá-los, siga estas etapas:
-
Criar um backup de banco de dados.
-
Use uma ferramenta de banco de dados como phpMyAdmin ou acesse o BD manualmente a partir da linha de comando para executar a seguinte consulta SQL:
code language-sql SELECT * FROM core_config_data WHERE (path = "web/cookie/cookie_domain" OR path = "web/cookie/cookie_path");
-
Se as respostas dos valores não estiverem vazias, defina-as como NULL executando:
code language-sql UPDATE core_config_data SET value = NULL WHERE (path = "web/cookie/cookie_domain" OR path = "web/cookie/cookie_path");
-
Limpe o cache de configuração executando o seguinte comando:
code language-bash php <your_magento_install_dir>/bin/magento cache:clean config
Artigos relacionados
- Redirecione de volta para o formulário de logon do Administrador com o erro "Sua conta está temporariamente desabilitada" em nossa knowledge base de suporte.
- Redirecione de volta para o formulário de logon do Administrador com o erro "Sua sessão atual expirou" em nossa base de dados de conhecimento de suporte.