O cache invalidado causa degradação do tempo de resposta
Este artigo explica como evitar a invalidação de cache, o que pode prejudicar o desempenho da loja do Adobe Commerce.
Descrição description
Ambiente
Adobe Commerce no local
Adobe Commerce na infraestrutura em nuvem
Problema/Sintomas
- Resposta lenta do site
Causa
Longos tempos de resposta podem ocorrer quando o cache é invalidado (liberado).
O cache ajuda a gerar respostas rápidas para as solicitações dos visitantes do site. Se nenhum dado de cache apropriado estiver disponível, o Adobe Commerce recuperará os dados do banco de dados, calculará e agregará os dados e os armazenará no cache. Esse processo requer recursos adicionais do sistema, o que pode degradar o tempo de resposta.
O Adobe Commerce usa dois tipos de cache:
- Interno Armazena dados no servidor, incluindo configuração, detalhes do produto e detalhes da categoria.
- CDN ou Verniz Externo (Fastly CDN para Adobe Commerce na nuvem). Armazena páginas completas, como páginas de catálogo/categoria e catálogo/produto.
Verifique se o cache foi invalidado
Para verificar tipos de cache invalidados no <install_directory> /var/log/debug.log
-
Abrir
<install_directory> /var/log/debug.log. -
Procure por " cache_invalidate ".
-
Revise a tag especificada:
cat_p- cache do produto de catálogocat_c- cache de categoria de catálogoFPC- cache de página inteiraCONFIG- cache de configuração
Mesmo que um deles fosse liberado, a resposta do site ficaria mais lenta. Se a marca incluir uma ID de entidade (por exemplo, category_product_1258), somente esse produto ou cache de categoria será liberado, o que normalmente não afeta significativamente o tempo de resposta.
A seguir está uma amostra de um debug.log que contém registros sobre o cache cat_p e category_product_15044 que foram liberados:
Motivos comuns para a invalidação de cache:
- Reindexação completa
- Liberação de cache a partir da CLI, manualmente ou via cron
Resolução resolution
Recomendação
- Evite liberar o cache da CLI do Commerce.
- Configure indexadores para Atualizar por agendamento em vez de Atualizar ao salvar para impedir a reindexação completa. Consulte Gerenciar os indexadores
>Configurar indexadores na documentação do desenvolvedor.