Erro ao limpar o cache do Fastly na Nuvem (A solicitação de limpeza não foi processada com êxito)

Este artigo fornece uma correção para quando você usa uma opção de limpeza Fastly e recebe o erro: A solicitação de limpeza não foi processada com êxito. O Fastly é um serviço de CDN e armazenamento em cache incluído no Adobe Commerce para planos e implementações de infraestrutura em nuvem. Se você tentar usar uma opção de limpeza do Fastly sem processar, talvez você tenha credenciais incorretas no ambiente ou tenha encontrado um problema.

Estas informações ajudam a verificar e testar os cabeçalhos do Fastly no site ativo e nos servidores de origem.

Versões afetadas

  • Adobe Commerce na infraestrutura em nuvem 2.1.X e posterior
  • Fastly 1.2.27 e posterior

Problema

O armazenamento em cache está funcionando, mas quando você tenta limpar, você recebe um erro ou ele não funciona. O erro inclui: "A solicitação de limpeza não foi processada com êxito."

Causa

Talvez você tenha credenciais incorretas definidas no ambiente ou precise fazer upload de trechos de VCL.

Resolver

Verificar credenciais do Fastly

Verifique se você tem a ID de serviço Fastly e o token da API no seu ambiente. Se você tiver credenciais de armazenamento temporário em produção, as remoções podem não ser processadas ou processadas incorretamente.

  1. Faça logon no Administrador local do Commerce como administrador.
  2. Clique em Lojas > Configurações > Configuração > Avançado > Sistema e expanda Cache de Página Inteira. magento_full_page_cache_2.4.1.png
  3. Expanda Configuração do Fastly e verifique a ID do Serviço Fastly e o token da API para seu ambiente.
  4. Se você modificar os valores, clique em Testar credenciais.

Verificar trechos de VCL

Se as credenciais estiverem corretas, você poderá ter problemas com suas VCLs. Para listar e revisar suas VCLs por serviço, insira a seguinte chamada de API em um terminal:

curl -X GET -s https://api.fastly.com/service/<Service ID>/version/<Editable Version #>/snippet -H "Fastly-Key:FASTLY_API_TOKEN"

Revise a lista de VCLs. Se tiver problemas com os VCLs padrão do Fastly, você poderá carregar novamente ou verificar o conteúdo de acordo com os VCLs padrão do Fastly. Para editar seus VCLs personalizados, consulte Fragmentos de VCL personalizados no Guia de Infraestrutura do Commerce na Nuvem.

Mais informações

Em nossa documentação do desenvolvedor:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a