Não é possível acessar o Adobe Commerce no repositório de nuvem: erro 403 proibido ou 404 não encontrado ao implantar

Para resolver erros de implantação do Adobe Commerce, como 403 Proibido ou 404 Não Encontrado, obtenha chaves de autorização válidas e verifique se elas estão especificadas corretamente na variável env:COMPOSER_AUTH e no arquivo auth.json.

Observação: ter apenas chaves de autorização válidas não garante acesso ao código. Se houver um problema de faturamento ou se seu contrato tiver expirado, você perderá o acesso ao código e a capacidade de enviar tíquetes de suporte.

Descrição description

Ambiente

Adobe Commerce na infraestrutura em nuvem versões 2.2.x, 2.3.x e 2.4.x

Problema/Sintomas

Ao implantar o Adobe Commerce na infraestrutura em nuvem, você pode encontrar erros indicando que o URL do repositório não pôde ser acessado, resultando em falha na implantação. No log de erros de implantação na interface do Project, uma mensagem de erro semelhante à seguinte é exibida:

A URL ‘https://repo.magento.com/archives/magento/magento-cloud-configuration/magento-magento-cloud-configuration-x.x.x.x.zip’ não pôde ser acessada: HTTP/1.1 403 Forbidden

OU


Não foi possível baixar o arquivo 'https://repo.magento.com/archives/magento/module-customer-segment/magento-module-customer-segment-x.x.x.x-patchY.zip' (HTTP/1.1 404 Não Encontrado)

(Clique no ícone Falha na interface do usuário do projeto para ver o log.)

Causa

A principal causa desses erros é chaves de autorização inválidas ou especificadas incorretamente. Isso pode ocorrer devido a:

  • Uso de chaves geradas de uma conta compartilhada
  • Revogação de licença devido a problemas de pagamento
  • As chaves configuradas foram excluídas da conta
  • Uso de chaves de autenticação diferentes em env:COMPOSER_AUTH e auth.json, o que pode causar conflitos de qualificação e falhas de download de pacote
  • O direito ao Adobe Commerce foi movido para uma conta diferente (ID de MAGE), enquanto o ambiente continua a usar chaves de autenticação do Composer geradas na conta anterior/descontinuada.

Observação: se você achar que isso se deve a um problema de faturamento ou de contrato expirado, entre em contato com a equipe de conta da Adobe para obter orientação para resolver isso. Depois que sua licença for reativada, seus direitos de suporte e implantação serão restaurados.

Resolução resolution

Antes de começar: verifique se você está usando chaves de autenticação Composer geradas na conta do Adobe Commerce atualmente intitulada. As chaves geradas em uma conta anterior ou descontinuada não funcionarão.

Etapa 1: gerar novas chaves de autenticação

  1. Entre em contato com o proprietário da licença da Adobe Commerce para gerar novas chaves de autenticação se você estiver usando chaves criadas em uma conta compartilhada. Se sua licença foi revogada anteriormente devido a problemas de pagamento e foi renovada, você deve
    gerar novas chaves de autenticação.
  2. Se o proprietário da conta não puder entrar no
    Adobe Commerce Marketplace,
    enviar um
    solicitação de suporte
    por meio da Adobe Experience League.
  3. Se o proprietário da conta puder entrar, verifique se
    A ID da MAGE
    está associada ao endereço de email correto. Se a associação estiver incorreta, abra um tíquete de suporte do Marketplace usando
    Contate-nos,
    ou email
    Suporte da Commerce Marketplace
    para solicitar uma atualização.

Etapa 2: atualizar a configuração de autenticação do Composer

Adicione as chaves de autenticação à variável env:COMPOSER_AUTH ou verifique se os valores corretos já estão configurados. Verifique se os valores estão consistentes no nível do projeto, no nível do ambiente e no arquivo auth.json (se presente). Para obter detalhes, consulte Preparar o sistema existente.

Etapa 3: atualizar ou remover auth.json

Se você usar a variável env:COMPOSER_AUTH, a Adobe recomenda remover auth.json do projeto para evitar credenciais conflitantes. Se você mantiver o arquivo, verifique se ele contém as chaves de autenticação corretas.

Faça logon na máquina que tem as chaves SSH da infraestrutura em nuvem do Adobe Commerce e, em seguida, faça logon no projeto:

magento-cloud login

Crie uma ramificação para atualizar a configuração (por exemplo, auth):

magento-cloud environment:branch auth

Na raiz do projeto, abra auth.json em um editor de texto e atualize-o conforme necessário:

{
  "http-basic": {
    "repo.magento.com": {
      "username": "<public_key>",
      "password": "<private_key>"
    }
  }
}

Etapa 4: Confirmar alterações e implantar

Salve as alterações, confirme-as e envie-as para o repositório:

git add -A
git commit -m "<message>"
git push origin master

Monitore o status da implantação na interface do usuário do projeto e confirme se os downloads do pacote foram concluídos com êxito.

Leitura relacionada

Erro de credenciais de autenticação do Composer durante a implantação para produção na Adobe Commerce Cloud

recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f