E: Erro ao verificar o erro route.yaml durante a implantação de preparo ou produção
Este artigo fornece uma solução para o problema de infraestrutura na nuvem do Adobe Commerce, em que você recebe a mensagem de erro "E: Erro ao verificar rotas.yaml" ao tentar implantar o projeto no ambiente de preparo ou produção.
Versões afetadas
- Adobe Commerce na infraestrutura em nuvem, todas as versões
Problema
Etapas a serem reproduzidas:
Acione uma implantação enviando o código para o ambiente de preparo ou produção.
Comportamento esperado:
Implantação bem-sucedida.
Comportamento real:
A implantação está bloqueada e a seguinte mensagem de erro é exibida no log:
Implantação de aplicativos Verificação da configuração E: erro ao verificar route.yaml.
Os domínios a seguir estão configurados para o cluster, mas não têm rotas definidas no arquivo route.yaml:
- store1.example.com
- store2.example.com
- test-store.example.com
Com sua configuração atual route.yaml,
esses domínios NÃO seriam atendidos!
Para continuar, consulte aqui para obter instruções sobre como solucionar problemas:
/help/troubleshooting/deployment/e-error-verifying-routes-yaml-error-during-staging-or-production-deploy.md
Causa
Este erro ocorre se a configuração de rota para quaisquer domínios adicionais que foram adicionados ao seu projeto estiverem ausentes do arquivo routes.yaml
.
Como parte da atualização de habilitação de autoatendimento do Adobe Commerce para configuração de rota de autoatendimento, adicionamos uma verificação de pré-implantação para garantir que todos os domínios no seu projeto tenham rotas configuradas no arquivo routes.yaml
. Se algum domínio não tiver configuração de rota, a implantação será bloqueada.
Solução
Para resolver a implantação bloqueada, atualize o arquivo routes.yaml
para configurar rotas para os domínios listados na mensagem de erro usando um dos seguintes métodos:
- Aplique o patch fornecido pelo Adobe Commerce durante o processo de atualização.
- Adicionar manualmente a configuração de rota ausente ao arquivo
routes.yaml
.
Método 1: aplicar o patch fornecido pelo Adobe Commerce
- Procure um tíquete de suporte recente da Adobe Commerce com o título "Habilitar recursos de autoatendimento para <project_ID>".
- Siga as instruções no tíquete para aplicar o patch, que atualiza a configuração de rota para o seu ambiente de nuvem.
- СConfirme e envie as alterações para reimplantar seu projeto.
Método 2: adicionar manualmente a configuração de rota ausente
-
Para servir todos os domínios em seu projeto usando a mesma configuração de rota, atualize o arquivo
routes.yaml
adicionando modelos de rota para o domínio padrão e todos os outros domínios em seu projeto, conforme mostrado no exemplo a seguir:code language-yaml "http://{default}/": type: upstream upstream: "mymagento:http" "http://{all}/": type: upstream upstream: "mymagento:http"
-
СConfirme e envie suas alterações para reimplantar seu projeto.
Para obter instruções detalhadas sobre como atualizar a configuração de rota, consulte Cloud para Adobe Commerce > Configurar rotas na documentação do desenvolvedor.
routes.yaml
para remover todas as referências aos domínios obsoletos.