Afhandeling is vastgelopen wanneer de betalingsmethode Authorize.net wordt gebruikt

Dit artikel verstrekt een verklaring en moeilijke situatie voor de Adobe Commerce 2.3.X kwestie waar het uitchecken wordt geplakt als Authorize.net wordt gebruikt, met "Kan bezit "lengte"van ongeldig"niet lezen foutenmelding in het logboek van de browser console.

Betrokken producten en versies

  • Adobe Commerce 2.3.X
NOTE
De belangrijkste integratie van Adobe Commerce Authorize.Net voor betalingen is afgekeurd sinds 2.3.4 en is volledig verwijderd in 2.4.0. Gebruik een uitbreiding die uw behoeften van Adobe Commerce Marketplacein plaats daarvan aanpast.

Probleem

Stappen om te reproduceren

  1. Configureer de betalingsmethode Authorize.net in Commerce Admin.
  2. Ga naar de winkel.
  3. Voeg een product toe aan het winkelwagentje en ga verder met het afrekenen.
  4. Kies Authorize.net als betalingsmethode.
  5. Klik de Orde van de Plaats.

Verwacht resultaat

Het iframe Authorize.net wordt geladen.

Werkelijk resultaat

Ajax spinner wordt weergegeven en de pagina wordt nooit geladen. De volgende JS-fout wordt weergegeven in het browserconsolelogboek: 'Uncaught TypeError: Cannot read property 'length' of null at b (jstest.authorize.net/v1/AcceptCore.js:1)'

Oorzaak

Één van de gemeenschappelijkste redenen voor deze kwestie is de Openbare Sleutel van de Cliënt die niet in de Authorize.Net configuratie in Commerce Admin wordt gespecificeerd.

Oplossing

Onder Opslag > Montages > Configuratie > Verkoop > de Methoden van de Betaling, in de Authorize.net sectie, controleer als de waarde in het Openbare Sleutel van de Cliënt gebied wordt gespecificeerd. Als het leeg is, ga de belangrijkste waarde van uw Authorize.Net handelsrekening in.

Maak de cache schoon door de wijzigingen uit te voeren

bin/magento cache:clean
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a