Nieuwe klanten die na CSV-import niet worden weergegeven in het klantenraster
Dit artikel verstrekt een moeilijke situatie voor de kwestie wanneer u geen nieuwe klanten onder Klanten kunt zien > Alle klanten na de invoer van een .csv dossier. De oplossing is om de customer_grid indexer in te stellen op de modus "Bijwerken bij opslaan" en het klantenraster handmatig opnieuw te indexeren.
Beschrijving description
Betrokken versies
- Adobe Commerce op locatie 2.2.0 en hoger
- Adobe Commerce over cloudinfrastructuur 2.2.0 en hoger
Probleem
Na het invoeren van nieuwe klanten van a .csv dossier gebruikend de inheemse de invoerfunctionaliteit van Adobe Commerce, zou u de nieuwe klantenverslagen onder Klanten kunnen niet zien > Alle klanten in Admin tot u manueel de customer_grid indexeerder opnieuw indexeert.
Oorzaak
De indexeringsmodus "Update on Schedule" in Adobe Commerce 2.2.0 en hoger ondersteunt de indexeringsmodus "Update on Schedule" in Adobe Commerce 2.2.0 en hoger niet de indexeermodus customer_grid vanwege prestatieproblemen.customer_grid
Resolutie resolution
Configureer de customer_grid -indexeerfunctie die opnieuw moet worden ingesteld met de modus "Bijwerken bij opslaan". Voer hiertoe de volgende stappen uit:
- Meld u aan bij de Commerce-beheerder.
- Klik Systeem
>Hulpmiddelen>Indexbeheer . - Schakel het selectievakje naast de indexeerfunctie voor klantenraster in.
- In de drop-down lijst van Acties , uitgezochte Update op sparen.
- Klik voorleggen .
We raden u ook aan de indexeerfunctie van customer_grid handmatig opnieuw te indexeren nadat u de indexmodus hebt geconfigureerd om ervoor te zorgen dat de index up-to-date is en met uitsnijden kan werken. Gebruik de volgende opdracht om opnieuw te indexeren: bin/magento indexer:reindex customer_grid