robots.txt niet bijgewerkt of standaardinstellingen weergeven
Dit artikel biedt een oplossing voor gevallen waarin het robots.txt
-bestand in Adobe Commerce correct is geconfigureerd, maar wel de standaardinstellingen weergeeft of niet bijwerkt. U kunt dit probleem oplossen door indexering door zoekmachines in te schakelen.
Beschrijving
Omgeving
Adobe Commerce op cloudinfrastructuur 2.4.x
Probleem
Kan de standaardinstellingen robots.txt
in Adobe Commerce niet wijzigen.
Stappen om te reproduceren :
- Open het deelvenster Beheer.
- Ga aan Inhoud
>
Ontwerp>
Configuratie , geef dan de instructie van de Douane van robots.txt gebied uit. - Voeg aangepaste inhoud toe (bijvoorbeeld de tekst "hello") en sla de wijzigingen op.
- Ga naar de
robots.txt
URL.
Verwacht resultaat :
In het robots.txt
-bestand wordt de opgeslagen aangepaste inhoud weergegeven.
Ware resultaat :
Het robots.txt
-bestand verandert niet en blijft de standaardinhoud weergeven.
Oorzaak
Indexering door zoekmachines is uitgeschakeld, waardoor de aangepaste robots.txt
-inhoud niet kan worden toegepast.
Resolutie
Methode 1: op de Console van de Wolk van de Handel van Adobe, vorm het indexeren door onderzoeksmotorenzoals die in onze ontwikkelaarsdocumentatie wordt beschreven.
Methode 2: Gebruikend magento-wolk CLI, stel het volgende bevel in werking:
magento-cloud environment:info -p <cluster> -e production restrict_robots false