Magento Order Management System (OMS) for Adobe Commerce times out

Dit artikel verstrekt een oplossing voor de kwestie waar het Systeem van het Magento Order Management (OMS) voor Adobe Commerce niet de plaatselijk geïnstalleerde micro-dienst met MOM kan registreren gebruikend inboei, omdat MOM tijden uit wanneer het proberen om terug te roepen.

Betrokken producten en versies

  • Adobe Commerce 2.3.1
  • OMS
  • ngrot
WARNING
Disclaimer: Adobe Commerce beveelt geen specifiek instrument aan of bekrachtigt geen specifiek instrument voor het aanleggen van tunnels. Het voorgaande is alleen suggesties. Voor meer informatie, raadpleeg de documentatie van het Ingrok.

Probleem

Stappen om te reproduceren

  1. Installeer Adobe Commerce in uw lokale omgeving.
  2. Stel een naam in om een tunnel te maken om uw lokale server toegankelijk te maken.
  3. Probeer verbindend met OMS.

Verwacht resultaat

Verbinding tot stand gebracht.

Werkelijk resultaat

MCOM lijkt een time-out op te geven wanneer wordt geprobeerd terug te bellen naar de URL van het knooppunt.

Oorzaak

Een van de mogelijke redenen voor de time-out is dat servers zich te ver van de locatie bevinden en dat de verbinding te veel tijd in beslag neemt.

Oplossing

Voeg een parameter toe die het gebied aangeeft wanneer u het notitieankerpunt start. Als het volgende:

./ngrok http 80 -region eu

Het standaardgebied is US. Zie alle mogelijke waarden.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a