MDVA-23764 Magento patch: error when loading dynamic block

Met de MDVA-23764-patch voor Magento's wordt de fout in

JsFooterPlugin.php

die de weergave van dynamische blokken beïnvloedt. Deze pleister is beschikbaar wanneer de Kwaliteitspatches (QPT) 1.0.13 is geïnstalleerd. De kwestie is in Magento 2.3.5 opgelost.

Betrokken producten en versies

De patch wordt gemaakt voor versie van Magento: Magento Commerce Cloud 2.3.3.

Compatibel met Magento's versies: Magento Commerce en Magento Commerce Cloud 2.3.2 - 2.3.4-p2.

NOTE
De patch kan van toepassing worden op andere versies met nieuwe versies van het Hulpprogramma voor kwaliteitspatches. Als u wilt controleren of de patch compatibel is met uw Adobe Commerce-versie, werkt u de magento/quality-patches het pakket aan de recentste versie en controleer verenigbaarheid op Quality Patches Tool: Pagina met patches zoeken. Gebruik de patch-id als een zoekwoord om de patch te zoeken.

Probleem

Stappen om te reproduceren:

Laad een URL die er als volgt uitziet: https://[magento domain]/banner/ajax/load/.

Werkelijk resultaat:

Er wordt een fout gegenereerd die vergelijkbaar is met het volgende: Uncaught TypeError: strpos() verwacht dat parameter 1 een tekenreeks is, null gegeven in…(coderegel) .

Verwacht resultaat:

URL wordt zonder fouten geladen.

De patch toepassen

Voor instructies over hoe te om een flard QPT toe te passen, gebruik de volgende verbindingen afhankelijk van uw product van het Magento:

Gerelateerde lezing

Raadpleeg voor meer informatie over het gereedschap Kwaliteitspatches:

Raadpleeg voor meer informatie over andere patches die beschikbaar zijn in het gereedschap QPT de Reparaties beschikbaar in het gereedschap QPT sectie.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a