De zoekfunctie voor MySQL-catalogus wordt verwijderd uit Adobe Commerce 2.4.0

Adobe Commerce op locatie, Adobe Commerce op cloudinfrastructuur en Magento Open Source 2.4.0 worden de komende maanden vrijgegeven. Voor Adobe Commerce on-premisse en Magento Open Source versie 2.4.0 zal de Elasticsearch 6.x of 7.x een vereiste component zijn, en MySQL onderzoeksmotor zal worden verwijderd. In Adobe Commerce op cloudinfrastructuur is Elasticsearch al vereist.

WARNING
Als u Elasticsearch 6/7 niet installeert/configureert voordat u probeert een upgrade uit te voeren, kunnen er ernstige problemen optreden met Adobe Commerce. Houd er rekening mee dat serviceupgrades op Adobe Commerce op cloudinfrastructuur niet naar de productieomgeving kunnen worden verplaatst zonder dat het infrastructuurteam hiervan 48 kantooruren op de hoogte wordt gesteld. Dit is nodig omdat wij ervoor moeten zorgen dat wij een ingenieur van de infrastructuursteun beschikbaar hebben om uw configuratie binnen een gewenst tijdsbestek met minimale onderbreking aan uw productiemilieu bij te werken. Dus 48 uur voor het moment dat uw veranderingen in productie moeten zijn een ondersteuningsticket indienen het gedetailleerd van uw vereiste de dienstverbetering en het verklaren van de tijd wanneer u het verbeteringsproces wilt beginnen.

De reden voor het verwijderen van MySQL zoekmachine is dat Elasticsearch betere zoekmogelijkheden biedt en optimaliseert de catalogusprestaties.

Betrokken producten en versies:

  • Adobe Commerce op locatie v2.4.0
  • Magento Open Source v2.4.0

Upgrade uitvoeren:

Zoekmachine
Handeling
MySQL
U moet Elasticsearch installeren. Zie Elasticsearch installeren en configureren in onze ontwikkelaarsdocumentatie.
Elasticsearch (zonder vermelde versie)
U gebruikt Elasticsearch 2 en moet bijwerken naar Elasticsearch 7 (voorkeur) of 6. Zie Elasticsearch bijwerken en Commerce configureren voor gebruik van Elasticsearch in onze ontwikkelaarsdocumentatie voor meer informatie.
ELASTICSEARCH 5
ELASTICSEARCH 5 Einde van levensduur en is vervangen in Adobe Commerce 2.4.0. Bijwerken naar Elasticsearch 7 (voorkeur) of 6.
Elasticsearch 6 of 7
U hoeft geen aanvullende stappen uit te voeren voordat u de upgrade naar Adobe Commerce 2.4.0 uitvoert.
Extensie door derden
U hoeft Elasticsearch niet te installeren. Adobe Commerce raadt u aan contact op te nemen met de leverancier van het zoekprogramma om te bepalen of uw extensie volledig compatibel is met Adobe Commerce 2.4.0.

Installatie:

Wanneer Adobe Commerce op-gebouw en Magento Open Source 2.4.0 wordt vrijgegeven, zal de Elasticsearch een vereist onderdeel zijn, zodat moet u een Elasticsearch gastheeropstelling hebben en voorafgaand aan het installeren van versie 2.4.0 worden gevormd. Zie Elasticsearch installeren en configureren in onze ontwikkelaarsdocumentatie.

Standaard gebruikt Adobe Commerce search Elasticsearch 7 als zoekengine en probeert het verbinding te maken met een server op localhost:9200. Elasticsearch 6.x wordt ook ondersteund. Als uw configuratie niet de gebreken aanpast, kunt u deze montages vormen gebruikend argumenten tot setup:install, op ongeveer de zelfde manier wordt de gegevensbestandverbinding gevormd.

Bijvoorbeeld: setup:install --elasticsearch-host=es.mystore.com

Tijdens de installatie wordt de verbinding met de Elasticsearch gecontroleerd en mislukt de installatie als Adobe Commerce geen verbinding kan maken met een Elasticsearch-host. Als dit voorkomt, controleer dat uw Elasticsearch in gebruik is, en dat u de correcte verbindingsparameters hebt verstrekt.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a