클라우드 인프라의 Adobe Commerce에서 New Relic 문제 해결

이 문서에서는 클라우드 인프라에서 Adobe Commerce의 New Relic 문제를 해결하는 데 필요한 리소스를 제공합니다.

문제
원인
리소스
액세스 문제

New Relic에서 프로젝트를 볼 수 없습니다.

New Relic 에 로그인했지만 보기/액세스 권한이 있는 프로젝트를 볼 수 없습니다.

이러한 경우 관리자는 사용자를 프로젝트에 추가해야 합니다.
지원 기술 자료에서 New Relic 서비스에 액세스.
데이터 문제

설치 후 데이터가 누락되었습니다.

New Relic 진단 유틸리티를 사용하여 원인을 식별하십시오. 도움이 되지 않는 경우 에이전트별 솔루션을 확인하십시오. 이러한 솔루션이 포함된 문서에 대한 링크는 오른쪽 열에 있습니다.

데이터 누락의 원인은 다를 수 있습니다. 다음을 수행해야 합니다.

  • 에이전트가 설치되었는지 확인합니다.
  • 앱 이름 및 라이선스 키를 확인합니다.
  • 웹 서버를 다시 시작합니다.
  • 시스템이 호환성 요구 사항을 충족하는지 확인합니다.
  • INI 설정.
트랜잭션 타임스탬프 불일치. New Relic UI를 사용하여 긴 트랜잭션(5분 이상)을 찾기 어려울 수 있습니다. 예상 시간대 외부에 표시되는 트랜잭션을 찾을 수도 있습니다.
New Relic UI에는 트랜잭션이 시작된 시간이 아니라 트랜잭션 종료 시간이 표시됩니다.
New Relic UI를 사용하여 거래 시작을 계산하려면 거래 기간을 확인하십시오. New Relic UI에서 제공한 타임스탬프(트랜잭션 종료)에서 기간 금액을 뺍니다.
|%과(와) 같은 특수 문자를 사용하는 NerdGraph GraphQL curl 쿼리가 작동하지 않습니다.
NerdGraph 내의 New Relic "curl로 복사" 기능은 현재 |%과(와) 같은 특수 문자를 처리하는 방법을 제공하지 않습니다.
다른 API 라이브러리를 사용하여 특수 문자로 문제를 해결합니다. 예를 들어 Python의 Graphql API용 GraphQLClient 라이브러리 또는 Java 언어 호출별 Apache.commons입니다. GraphQL에서 클라이언트 라이브러리를 검토하십시오.
차트 및 대시보드 표시 문제
New Relic 도메인을 허용 목록에 추가하거나 문제를 일으키는 브라우저 확장을 제거하여 누락된 차트를 해결합니다.
New Relic 설명서 > 차트가 없거나 렌더링되지 않음
PHP 에이전트 문제
PHP 에이전트가 올바른 인스턴스 수를 표시하지 않습니다.
백엔드 프로세스와 처리량에 따라 인스턴스 수가 늘어날 수 있습니다. 서버 값 간의 차이는 한 서버에서 실행 중인 프로세스로 인해 발생할 수 있지만 다른 서버에서는 발생하지 않습니다.
New Relic 설명서 > PHP 에이전트 인스턴스 수 문제 해결
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a