무효화된 캐시는 응답 시간 저하를 유발합니다.

이 문서에서는 Adobe Commerce 저장소 성능을 저하시킬 수 있는 캐시 무효화를 방지하는 방법에 대해 설명합니다.

설명 description

환경

Adobe Commerce 온-프레미스

클라우드 인프라의 Adobe Commerce

문제/증상

  • 사이트 응답 속도 저하

원인

캐시를 무효화(플러시)하면 응답 시간이 길어질 수 있습니다.

캐시는 사이트 방문자의 요청에 대한 빠른 응답을 생성하는 데 도움이 됩니다. 적절한 캐시 데이터를 사용할 수 없는 경우 Adobe Commerce은 데이터베이스에서 데이터를 검색하고 계산 및 집계하여 캐시에 저장합니다. 이 프로세스에는 추가 시스템 리소스가 필요하므로 응답 시간이 저하될 수 있습니다.

Adobe Commerce에서는 두 가지 유형의 캐시를 사용합니다.

  • 내부 구성, 제품 세부 정보 및 범주 세부 정보를 포함하여 서버에 데이터를 저장합니다.
  • 외부 CDN 또는 바니시(클라우드에서 Adobe Commerce에 대한 Fastly CDN). 카탈로그/카테고리 및 카탈로그/제품 페이지와 같은 전체 페이지를 저장합니다.

캐시를 무효화했는지 확인

<install_directory> /var/log/debug.log에서 무효화된 캐시 형식을 확인하려면

  1. <install_directory> /var/log/debug.log. 열기

  2. "cache_invalidate" 검색

  3. 지정된 태그를 검토합니다.

    • cat_p - 카탈로그 제품 캐시
    • cat_c - 카탈로그 범주 캐시
    • FPC - 전체 페이지 캐시
    • CONFIG - 구성 캐시

둘 중 하나라도 플러시하면 웹 사이트의 응답이 느려집니다. 태그에 엔터티 ID가 포함된 경우(예: category_product_1258) 해당 제품 또는 범주 캐시만 플러시되었으며, 이는 일반적으로 응답 시간에 큰 영향을 주지 않습니다.

다음은 플러시된 debug.logcat_p 캐시에 대한 레코드가 포함된 category_product_15044의 샘플입니다.

캐시 무효화에 대한 일반적인 이유:

  • 전체 색인 재지정
  • 수동으로 또는 cron 을 통해 CLI에서 캐시 플러시

해결 방법 resolution

권장 사항

  1. Commerce CLI에서 캐시를 플러시하지 마십시오.
  2. 전체 리인덱싱을 방지하려면 인덱서를 저장 시 업데이트 대신 일정별로 업데이트하도록 구성하십시오. 개발자 설명서에서 인덱서 관리 > 인덱서 구성을(를) 참조하십시오.
recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f