Adobe Commerce 버전 2.3.4-p1 또는 2.3.5로 업그레이드하는 동안 위시리스트 오류 발생

이 문서에서는 이러한 버전으로 업그레이드하는 동안의 위시리스트 오류와 관련된 Adobe Commerce 버전 2.3.4-p1 및 2.3.5로 업그레이드할 때 발생하는 알려진 문제에 대한 수정 사항을 제공합니다.

영향을 받는 제품 및 버전

  • 클라우드 인프라 2.3.4-p1 및 2.3.5의 Adobe Commerce
  • Adobe Commerce 온-프레미스 2.3.4-p1 및 2.3.5

문제

Adobe Commerce(모든 배포 방법) 및 Magento Open Source을 버전 2.3.5 또는 2.3.4-p1로 업그레이드할 때 모듈에서 위시리스트 오류(아래에 자세히 설명)가 표시될 수 있습니다.

Magento_Wishlist

Adobe Commerce(모든 배포 방법)/Magneto Open Source 버전 2.3.4-p1에서 업그레이드 대상 버전 2.3.4-p2 또는 Adobe Commerce(모든 배포 방법)/Magneto Open Source 버전 2.3.5에서 대상 버전 2.3.5-p1 이(가) 오류를 수정합니다.

재현 단계:

Adobe Commerce(모든 배포 방법)/Magento Open Source을 버전 2.3.4-p1 또는 2.3.5로 업그레이드하십시오.

예상 결과:

Adobe Commerce(모든 배포 방법)/Magento Open Source 버전 2.3.4-p1 또는 2.3.5로의 업그레이드 프로세스가 정상적으로 완료됩니다.

실제 결과:

업그레이드 중에 다음 오류가 발생합니다.

Module ‘Magento_Wishlist’:

Unable to apply data patch Magento\Wishlist\Setup\Patch\Data\CleanUpData for module Magento_Wishlist. Original exception message: Unable to unserialize value. Error: Syntax error

솔루션

  • Adobe Commerce(모든 배포 방법)/Magneto Open Source 버전 2.3.5로 업그레이드하는 경우 버전 2.3.5-p1로 업그레이드. Adobe Commerce(모든 배포 방법)/Magento Open Source 버전 2.3.5-p1은 2.3.5를 대체합니다.
  • Adobe Commerce(모든 배포 방법)/Magento Open Source 버전 2.3.4-p1로 업그레이드하는 경우 버전 2.3.4-p2로 업그레이드. Adobe Commerce(모든 배포 방법)/Magneto Open Source 버전 2.3.4-p2는 버전 2.3.4-p1을 대체합니다.

관련 읽기

개발자 설명서에서:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a