ACSD-53824: 설치 업그레이드 시 배포가 실패했습니다.

ACSD-53824 패치는 설치 업그레이드 시 배포가 실패하는 문제를 해결합니다. 이 패치는 다음 경우에 사용할 수 있습니다. Quality Patches Tool (QPT) 1.1.38이 설치되었습니다. 패치 ID는 ACSD-53824입니다. 이 문제는 Adobe Commerce 2.4.7에서 수정됩니다.

영향을 받는 제품 및 버전

패치는 Adobe Commerce 버전에 대해 만들어집니다.

  • Adobe Commerce(모든 배포 방법) 2.4.5 - p2

Adobe Commerce 버전과 호환:

  • Adobe Commerce(모든 배포 방법) 2.4.4 - 2.4.6-p2
NOTE
이 패치는 새 버전이 설치된 다른 버전에 적용할 수 있습니다 Quality Patches Tool 릴리스. 패치가 Adobe Commerce 버전과 호환되는지 확인하려면 magento/quality-patches 최신 버전으로 패키지하고 Quality Patches Tool: 패치 검색 페이지. 패치 ID를 검색 키워드로 사용하여 패치를 찾습니다.

문제

설치 업그레이드 시 배포가 실패했습니다.

재현 단계:

  1. 을 사용하여 인프라 설치 MariaDB 갈레라 클러스터에서.
  2. 설정 wsrep_max_ws_size 최대 2GB.
  3. 새 Adobe Commerce 인스턴스를 설치합니다.
  4. 중간 성능 프로파일에서 고정장치를 생성합니다.
    php bin/magento setup:performance:generate-fixtures -s setup/performance-toolkit/profiles/ee/medium.xml
  5. 보다 많은 항목 생성 12000 속성을 다중 선택합니다.
  6. 그런 다음 Run setup: Upgrade 명령입니다.

예상 결과:

다음 setup:upgrade 오류 없이 완료합니다.

실제 결과:

다음 setup:upgrade 다음으로 실패 MySQL 오류:

Allowed memory size of 6442450944 bytes exhausted in ../module-catalog/Setup/Patch/Data/UpdateMultiselectAttributesBackendTypes.php

패치 적용

개별 패치를 적용하려면 배포 방법에 따라 다음 링크를 사용합니다.

관련 읽기

에 대해 자세히 알아보기 Quality Patches Tool을(를) 참조하시기 바랍니다.

QPT에서 사용할 수 있는 다른 패치에 대한 정보는 다음을 참조하십시오. Quality Patches Tool: 패치 검색 다음에서 Quality Patches Tool 가이드.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a