ACSD-51471: 관리자가 번들 제품에 대해 예약된 업데이트를 저장할 수 없음

ACSD-51471 패치는 관리자가 업데이트가 예약된 간단한 제품을 사용하는 번들 제품에 대해 예약된 업데이트를 저장할 수 없는 문제를 해결합니다. 이 패치는 다음 경우에 사용할 수 있습니다. Quality Patches Tool (QPT) 1.1.33이 설치되었습니다. 패치 ID는 ACSD-51471입니다. 이 문제는 Adobe Commerce 2.4.7에서 수정됩니다.

영향을 받는 제품 및 버전

패치는 Adobe Commerce 버전에 대해 만들어집니다.

  • Adobe Commerce(모든 배포 방법) 2.4.5-p1

Adobe Commerce 버전과 호환:

  • Adobe Commerce(모든 배포 방법) 2.4.3 - 2.4.6-p1
NOTE
이 패치는 새 버전이 설치된 다른 버전에 적용할 수 있습니다 Quality Patches Tool 릴리스. 패치가 Adobe Commerce 버전과 호환되는지 확인하려면 magento/quality-patches 최신 버전으로 패키지하고 Quality Patches Tool: 패치 검색 페이지. 패치 ID를 검색 키워드로 사용하여 패치를 찾습니다.

문제

관리자는 자신에게 예약된 업데이트가 있는 간단한 제품을 사용하는 번들 제품에 대해 예약된 업데이트를 저장할 수 없습니다.

재현 단계:

  1. 간단한 제품을 만듭니다.
  2. 를 사용하는 단순 제품에 대해 예약된 업데이트를 추가합니다. 시작일 및 아니요 종료일.
  3. 업데이트가 적용된 후 제품의 SKU를 변경합니다.
  4. 번들 제품을 만들고 1단계에서 만든 간단한 제품을 하위 제품으로 추가합니다.
  5. 번들 제품에 대한 예정된 업데이트를 만들어 번들 제품을 활성화합니다. 둘 다 제공 시작일종료일 예약된 업데이트.
  6. 예약된 업데이트를 저장합니다.

예상 결과:

예약된 업데이트가 정상적으로 저장되었습니다.

실제 결과:

예약된 업데이트를 저장할 때 다음 오류가 발생합니다. 요청한 제품이 존재하지 않습니다. 제품을 확인하고 다시 시도하십시오.

패치 적용

개별 패치를 적용하려면 배포 방법에 따라 다음 링크를 사용합니다.

관련 읽기

에 대해 자세히 알아보기 Quality Patches Tool을(를) 참조하시기 바랍니다.

QPT에서 사용할 수 있는 다른 패치에 대한 정보는 다음을 참조하십시오. Quality Patches Tool: 패치 검색 다음에서 Quality Patches Tool 가이드.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a